[all-commits] [llvm/llvm-project] 5b144c: [AMDGPU] Add suffix _d4 to tensor load/store with ...

Changpeng Fang via All-commits all-commits at lists.llvm.org
Tue Mar 3 14:10:59 PST 2026


  Branch: refs/heads/main
  Home:   https://github.com/llvm/llvm-project
  Commit: 5b144c0aec63fe80a610b77e27de926869391b64
      https://github.com/llvm/llvm-project/commit/5b144c0aec63fe80a610b77e27de926869391b64
  Author: Changpeng Fang <changpeng.fang at amd.com>
  Date:   2026-03-03 (Tue, 03 Mar 2026)

  Changed paths:
    M clang/test/CodeGenOpenCL/builtins-amdgcn-gfx1250-tensor-load-store.cl
    M llvm/lib/Target/AMDGPU/AMDGPUISelDAGToDAG.cpp
    M llvm/lib/Target/AMDGPU/AMDGPUInstructionSelector.cpp
    M llvm/lib/Target/AMDGPU/MIMGInstructions.td
    M llvm/lib/Target/AMDGPU/SIInstrInfo.cpp
    M llvm/lib/Target/AMDGPU/SIInstrInfo.h
    M llvm/lib/Target/AMDGPU/Utils/AMDGPUBaseInfo.cpp
    M llvm/test/CodeGen/AMDGPU/llvm.amdgcn.tensor.load.store.ll
    M llvm/test/CodeGen/AMDGPU/reg-coalescer-subreg-liveness.mir

  Log Message:
  -----------
  [AMDGPU] Add suffix _d4 to tensor load/store with 4 groups D#, NFC (#184176)

Rename TENSOR_LOAD_TO_LDS to TENSOR_LOAD_TO_LDS_d4;
  Rename TENSOR_STORE_FROM_LDS to TENSOR_STORE_FROM_LDS_d4;
Also rename function names in a couple of tests to reflect this change.



To unsubscribe from these emails, change your notification settings at https://github.com/llvm/llvm-project/settings/notifications


More information about the All-commits mailing list