[all-commits] [llvm/llvm-project] 3862a4: [GlobalISel] Use named constant for impossible rep...
Eliz Habiboullah via All-commits
all-commits at lists.llvm.org
Mon Feb 9 02:19:08 PST 2026
Branch: refs/heads/main
Home: https://github.com/llvm/llvm-project
Commit: 3862a4f733002e90ecee7b79aca87bb46d5575b1
https://github.com/llvm/llvm-project/commit/3862a4f733002e90ecee7b79aca87bb46d5575b1
Author: Eliz Habiboullah <eliz4ads at gmail.com>
Date: 2026-02-09 (Mon, 09 Feb 2026)
Changed paths:
M llvm/lib/CodeGen/GlobalISel/RegBankSelect.cpp
Log Message:
-----------
[GlobalISel] Use named constant for impossible repair cost (#180490)
replace magic value `std::numeric_limits<unsigned>::max()` with a named
constant `ImpossibleRepairCost` to improve readability
To unsubscribe from these emails, change your notification settings at https://github.com/llvm/llvm-project/settings/notifications
More information about the All-commits
mailing list