[all-commits] [llvm/llvm-project] f4d4ca: [LLVM][CodeGen] Rename `gc-empty-basic-blocks` to ...

Rahul Joshi via All-commits all-commits at lists.llvm.org
Thu Jan 15 08:00:29 PST 2026


  Branch: refs/heads/main
  Home:   https://github.com/llvm/llvm-project
  Commit: f4d4caad946619841ea924526204ee99b99435d2
      https://github.com/llvm/llvm-project/commit/f4d4caad946619841ea924526204ee99b99435d2
  Author: Rahul Joshi <rjoshi at nvidia.com>
  Date:   2026-01-15 (Thu, 15 Jan 2026)

  Changed paths:
    M llvm/include/llvm/Target/CGPassBuilderOption.h
    M llvm/lib/CodeGen/TargetPassConfig.cpp
    M llvm/test/CodeGen/X86/basic-block-address-map-empty-block.ll
    M llvm/test/CodeGen/X86/gc-empty-basic-blocks.ll

  Log Message:
  -----------
  [LLVM][CodeGen] Rename `gc-empty-basic-blocks` to `enable-gc-empty-basic-blocks` (#176018)

Rename the `gc-empty-basic-blocks` command line option to
`enable-gc-empty-basic-blocks` in preparation of adding calls to
initializing the pass in `initializeCodeGen` and also make the flag more
consistent with other existing flags to enable or disable passes.

Keep `gc-empty-basic-blocks` as an alias to allow all users to migrate
to the new option.



To unsubscribe from these emails, change your notification settings at https://github.com/llvm/llvm-project/settings/notifications


More information about the All-commits mailing list