[all-commits] [llvm/llvm-project] c1625f: [orc-rt] Rename unique_function to move_only_funct...
Lang Hames via All-commits
all-commits at lists.llvm.org
Thu Aug 21 22:26:31 PDT 2025
Branch: refs/heads/main
Home: https://github.com/llvm/llvm-project
Commit: c1625fad023b964ba0a197eb25d9c86e330d63d6
https://github.com/llvm/llvm-project/commit/c1625fad023b964ba0a197eb25d9c86e330d63d6
Author: Lang Hames <lhames at gmail.com>
Date: 2025-08-22 (Fri, 22 Aug 2025)
Changed paths:
M orc-rt/include/CMakeLists.txt
A orc-rt/include/orc-rt/move_only_function.h
R orc-rt/include/orc-rt/unique-function.h
M orc-rt/unittests/CMakeLists.txt
A orc-rt/unittests/move_only_function-test.cpp
R orc-rt/unittests/unique-function-test.cpp
Log Message:
-----------
[orc-rt] Rename unique_function to move_only_function. (#154888)
This will allow the ORC runtime and its clients to easily adopt the
c++-23 std::move_only_function type.
To unsubscribe from these emails, change your notification settings at https://github.com/llvm/llvm-project/settings/notifications
More information about the All-commits
mailing list