[all-commits] [llvm/llvm-project] b2711e: [flang][nfc] Support volatile on ref, box, and cla...
Asher Mancinelli via All-commits
all-commits at lists.llvm.org
Mon Apr 7 06:51:23 PDT 2025
Branch: refs/heads/main
Home: https://github.com/llvm/llvm-project
Commit: b2711e1526f9384be4905f516a5503427e0bafd7
https://github.com/llvm/llvm-project/commit/b2711e1526f9384be4905f516a5503427e0bafd7
Author: Asher Mancinelli <ashermancinelli at gmail.com>
Date: 2025-04-07 (Mon, 07 Apr 2025)
Changed paths:
M flang/include/flang/Optimizer/Builder/FIRBuilder.h
M flang/include/flang/Optimizer/Dialect/FIRType.h
M flang/include/flang/Optimizer/Dialect/FIRTypes.td
M flang/lib/Optimizer/Builder/FIRBuilder.cpp
M flang/lib/Optimizer/Dialect/FIRType.cpp
M flang/test/Fir/invalid-types.fir
M flang/unittests/Optimizer/FIRTypesTest.cpp
Log Message:
-----------
[flang][nfc] Support volatile on ref, box, and class types (#134386)
Part one of merging #132486. Add support for representing volatility in
the type system for reference, box, and class types. Don't do anything
with volatile just yet, only support and test their representation and
utility functions.
The naming convention is a little goofy - `fir::isa_volatile_type` and
`fir::updateTypeWithVolatility` use different capitalization, but I put
them near similar functions and tried to match the surrounding
conventions and [the
docs](https://github.com/llvm/llvm-project/blob/main/flang/docs/C%2B%2Bstyle.md#naming)
best I could.
To unsubscribe from these emails, change your notification settings at https://github.com/llvm/llvm-project/settings/notifications
More information about the All-commits
mailing list