[all-commits] [llvm/llvm-project] 5c8c2b: [Flang] Rename libFortranRuntime.a to libflang_rt....

Michael Kruse via All-commits all-commits at lists.llvm.org
Sat Feb 8 09:03:15 PST 2025


  Branch: refs/heads/main
  Home:   https://github.com/llvm/llvm-project
  Commit: 5c8c2b3db54395073e3183f89167156df29dff61
      https://github.com/llvm/llvm-project/commit/5c8c2b3db54395073e3183f89167156df29dff61
  Author: Michael Kruse <llvm-project at meinersbur.de>
  Date:   2025-02-08 (Sat, 08 Feb 2025)

  Changed paths:
    M clang/lib/Driver/ToolChains/CommonArgs.cpp
    M clang/lib/Driver/ToolChains/Flang.cpp
    M flang/CMakeLists.txt
    M flang/cmake/modules/AddFlang.cmake
    M flang/docs/FlangDriver.md
    M flang/docs/GettingStarted.md
    M flang/docs/OpenACC-descriptor-management.md
    M flang/docs/Real16MathSupport.md
    M flang/docs/ReleaseNotes.md
    M flang/examples/ExternalHelloWorld/CMakeLists.txt
    M flang/lib/Optimizer/Builder/IntrinsicCall.cpp
    M flang/runtime/CMakeLists.txt
    M flang/runtime/CUDA/CMakeLists.txt
    M flang/runtime/Float128Math/CMakeLists.txt
    M flang/runtime/time-intrinsic.cpp
    M flang/runtime/tools.h
    M flang/test/CMakeLists.txt
    M flang/test/Driver/gcc-toolchain-install-dir.f90
    M flang/test/Driver/linker-flags.f90
    M flang/test/Driver/msvc-dependent-lib-flags.f90
    M flang/test/Driver/nostdlib.f90
    M flang/test/Runtime/no-cpp-dep.c
    M flang/test/lit.cfg.py
    M flang/tools/f18/CMakeLists.txt
    M flang/unittests/CMakeLists.txt
    M flang/unittests/Evaluate/CMakeLists.txt
    M flang/unittests/Runtime/CMakeLists.txt
    M flang/unittests/Runtime/CUDA/CMakeLists.txt
    M lld/COFF/MinGW.cpp

  Log Message:
  -----------
  [Flang] Rename libFortranRuntime.a to libflang_rt.runtime.a (#122341)

Following the conclusion of the
[RFC](https://discourse.llvm.org/t/rfc-names-for-flang-rt-libraries/84321),
rename Flang's runtime libraries as follows:

 * libFortranRuntime.(a|so) to libflang_rt.runtime.(a|so)
 * libFortranFloat128Math.a to libflang_rt.quadmath.a
* libCufRuntime_cuda_${CUDAToolkit_VERSION_MAJOR}.(a|so) to
libflang_rt.cuda_${CUDAToolkit_VERSION_MAJOR}.(a|so)

This follows the same naming scheme as Compiler-RT libraries
(`libclang_rt.${component}.(a|so)`). It provides some consistency
between Flang's runtime libraries for current and potential future
library components.



To unsubscribe from these emails, change your notification settings at https://github.com/llvm/llvm-project/settings/notifications


More information about the All-commits mailing list