[all-commits] [llvm/llvm-project] 51aceb: [llvm/llvm-project][Coroutines] Improve debugging ...
Tyler Nowicki via All-commits
all-commits at lists.llvm.org
Tue Aug 27 15:55:54 PDT 2024
Branch: refs/heads/main
Home: https://github.com/llvm/llvm-project
Commit: 51aceb5b30ff9934c476eeb5cd7ff584c3e27049
https://github.com/llvm/llvm-project/commit/51aceb5b30ff9934c476eeb5cd7ff584c3e27049
Author: Tyler Nowicki <tyler.nowicki at amd.com>
Date: 2024-08-27 (Tue, 27 Aug 2024)
Changed paths:
M llvm/lib/Transforms/Coroutines/CoroEarly.cpp
M llvm/lib/Transforms/Coroutines/CoroFrame.cpp
M llvm/lib/Transforms/Coroutines/CoroSplit.cpp
Log Message:
-----------
[llvm/llvm-project][Coroutines] Improve debugging and minor refactoring (#104642)
No Functional Changes
* Fix comments in several places
* Instead of using BB-getName() (in dump methods) use
getBasicBlockLabel. This fixes the poor output of the dumped info that
resulted in missing BB labels.
* Use RPO when dumping SuspendCrossingInfo. Without this the dump order
is determined by the ptr addresses and so is not consistent from run to
run making IR diffs difficult to read.
* Inference -> Interference
* Pull the logic that determines insertion location out of insertSpills
and into getSpillInsertionPt, to differentiate between these two
operations.
* Use Shape getters for CoroId instead of getting it manually.
---------
Co-authored-by: tnowicki <tnowicki.nowicki at amd.com>
To unsubscribe from these emails, change your notification settings at https://github.com/llvm/llvm-project/settings/notifications
More information about the All-commits
mailing list