[all-commits] [llvm/llvm-project] 640c85: [libc] fix readability-identifier-naming in memory...
Nick Desaulniers via All-commits
all-commits at lists.llvm.org
Tue Mar 5 08:17:02 PST 2024
Branch: refs/heads/main
Home: https://github.com/llvm/llvm-project
Commit: 640c85748ec823e91a3cd412829f644cf4f10ffc
https://github.com/llvm/llvm-project/commit/640c85748ec823e91a3cd412829f644cf4f10ffc
Author: Nick Desaulniers <nickdesaulniers at users.noreply.github.com>
Date: 2024-03-05 (Tue, 05 Mar 2024)
Changed paths:
M libc/src/string/memory_utils/op_generic.h
M libc/src/string/memory_utils/utils.h
Log Message:
-----------
[libc] fix readability-identifier-naming in memory_utils/utils.h (#83919)
Fixes:
libc/src/string/memory_utils/utils.h:345:13: warning: invalid case style
for member 'offset_' [readability-identifier-naming]
Having a trailing underscore for members is a google3 style, not LLVM style.
Removing the underscore is insufficient, as we would then have 2 members with
the same identifier which is not allowed (it is a compile time error). Remove
the getter, and just access the renamed member that's now made public.
To unsubscribe from these emails, change your notification settings at https://github.com/llvm/llvm-project/settings/notifications
More information about the All-commits
mailing list