[all-commits] [llvm/llvm-project] 33de5a: [libc++] Rename __fwd/hash.h to __fwd/functional.h...
Nikolas Klauser via All-commits
all-commits at lists.llvm.org
Sun Mar 3 11:45:28 PST 2024
Branch: refs/heads/main
Home: https://github.com/llvm/llvm-project
Commit: 33de5a316caa3c9b07ee1ccc7fbc3434247ff787
https://github.com/llvm/llvm-project/commit/33de5a316caa3c9b07ee1ccc7fbc3434247ff787
Author: Nikolas Klauser <nikolasklauser at berlin.de>
Date: 2024-03-03 (Sun, 03 Mar 2024)
Changed paths:
M libcxx/include/CMakeLists.txt
M libcxx/include/__filesystem/path.h
M libcxx/include/__functional/bind.h
M libcxx/include/__functional/hash.h
M libcxx/include/__functional/identity.h
A libcxx/include/__fwd/functional.h
R libcxx/include/__fwd/hash.h
M libcxx/include/__thread/id.h
M libcxx/include/__thread/support/pthread.h
M libcxx/include/__type_traits/is_reference_wrapper.h
M libcxx/include/__type_traits/unwrap_ref.h
M libcxx/include/experimental/propagate_const
M libcxx/include/filesystem
M libcxx/include/libcxx.imp
M libcxx/include/module.modulemap.in
M libcxx/include/optional
M libcxx/include/type_traits
M libcxx/test/libcxx/transitive_includes/cxx23.csv
M libcxx/test/libcxx/transitive_includes/cxx26.csv
M libcxx/utils/generate_iwyu_mapping.py
Log Message:
-----------
[libc++] Rename __fwd/hash.h to __fwd/functional.h and add reference_wrapper (#81445)
We forward declare `reference_wrapper` in multiple places already. This
moves the declaration to the canonical place and removes unnecessary
includes of `__functional/reference_wrapper.h`.
To unsubscribe from these emails, change your notification settings at https://github.com/llvm/llvm-project/settings/notifications
More information about the All-commits
mailing list