[all-commits] [llvm/llvm-project] da4d19: [mlir][tosa] operation printing syntax prettification

TatWai Chong via All-commits all-commits at lists.llvm.org
Tue Aug 15 11:18:32 PDT 2023


  Branch: refs/heads/main
  Home:   https://github.com/llvm/llvm-project
  Commit: da4d191ffe76efdfc3a1c67c438cb721fad83511
      https://github.com/llvm/llvm-project/commit/da4d191ffe76efdfc3a1c67c438cb721fad83511
  Author: TatWai Chong <tatwai.chong at arm.com>
  Date:   2023-08-15 (Tue, 15 Aug 2023)

  Changed paths:
    M mlir/include/mlir/Dialect/Tosa/IR/TosaOpBase.td
    M mlir/include/mlir/Dialect/Tosa/IR/TosaOps.td
    M mlir/include/mlir/Dialect/Tosa/IR/TosaUtilOps.td
    M mlir/lib/Dialect/Tosa/IR/TosaOps.cpp
    M mlir/test/Conversion/TosaToArith/tosa-to-arith.mlir
    M mlir/test/Conversion/TosaToLinalg/tosa-to-linalg-named.mlir
    M mlir/test/Conversion/TosaToLinalg/tosa-to-linalg.mlir
    M mlir/test/Conversion/TosaToSCF/tosa-to-scf.mlir
    M mlir/test/Dialect/Tosa/broadcast.mlir
    M mlir/test/Dialect/Tosa/canonicalize.mlir
    M mlir/test/Dialect/Tosa/constant-op-fold.mlir
    M mlir/test/Dialect/Tosa/constant_folding.mlir
    M mlir/test/Dialect/Tosa/fold_concats.mlir
    M mlir/test/Dialect/Tosa/invalid.mlir
    M mlir/test/Dialect/Tosa/ops.mlir
    M mlir/test/Dialect/Tosa/tosa-decompose-conv2d.mlir
    M mlir/test/Dialect/Tosa/tosa-decompose-depthwise.mlir
    M mlir/test/Dialect/Tosa/tosa-decompose-transpose-conv.mlir
    M mlir/test/Dialect/Tosa/tosa-infer-shapes.mlir
    M mlir/test/Dialect/Tosa/transpose-fold.mlir

  Log Message:
  -----------
  [mlir][tosa] operation printing syntax prettification

The initial patch defines the printing format of tosa operations in
declarative and C++ manners to make alignment against more readable
syntax in other dialects. The general change to assembly output is
shown below.

from
     %out = "tosa.op"(%input1, %input2, ...) : (type1, type2, ...) -> (out_type)
to
     %out = tosa.op %input1, %input2, ... : (type1, type2, ...) -> out_type

There is a significant structural printing change to tosa control-flow
operations, `cond_if` and `while_loop`, aiming to provide more concise
and intuitive syntax. Note that we leave tosa.const unchanged. As this
op can be attached with quantization information, may need more tweaks
to distinguish plain integer type from quantized type for printing the
value in a concise form.

Differential Revision: https://reviews.llvm.org/D155231




More information about the All-commits mailing list