[all-commits] [llvm/llvm-project] 47755e: [AppleAccelTable][NFC] Improve code readability

Felipe de Azevedo Piovezan via All-commits all-commits at lists.llvm.org
Thu Jun 8 13:36:45 PDT 2023


  Branch: refs/heads/main
  Home:   https://github.com/llvm/llvm-project
  Commit: 47755e1ff8f255d4f369269be078063dc53944ea
      https://github.com/llvm/llvm-project/commit/47755e1ff8f255d4f369269be078063dc53944ea
  Author: Felipe de Azevedo Piovezan <fpiovezan at apple.com>
  Date:   2023-06-08 (Thu, 08 Jun 2023)

  Changed paths:
    M llvm/lib/DebugInfo/DWARF/DWARFAcceleratorTable.cpp

  Log Message:
  -----------
  [AppleAccelTable][NFC] Improve code readability

This commit does a few minor NFC cleanups:

* A variable was called "Atom", probably trying to claim it was an AtomType.
This was incorrect, it is actually a FormValue.

* LLVM provides a `zip_equal` to express the intent of asserting ranges with the
same size. We change the lookup method to use that.

* The use of tuples made the code slightly difficult to follow, as such we
unpack the tuple with structure binding to improve readability.

Depends on D152157

Differential Revision: https://reviews.llvm.org/D152158




More information about the All-commits mailing list