[all-commits] [llvm/llvm-project] d088b8: [SLP] Rename IsUniformStride to IsUnitStride. NFCI

Luke Lau via All-commits all-commits at lists.llvm.org
Wed May 17 05:21:48 PDT 2023


  Branch: refs/heads/main
  Home:   https://github.com/llvm/llvm-project
  Commit: d088b8af937a7bfe09ab1b01d303e0b4f0e8f9e5
      https://github.com/llvm/llvm-project/commit/d088b8af937a7bfe09ab1b01d303e0b4f0e8f9e5
  Author: Luke Lau <luke at igalia.com>
  Date:   2023-05-17 (Wed, 17 May 2023)

  Changed paths:
    M llvm/include/llvm/Analysis/TargetTransformInfo.h
    M llvm/lib/Transforms/Vectorize/SLPVectorizer.cpp

  Log Message:
  -----------
  [SLP] Rename IsUniformStride to IsUnitStride. NFCI

IsUniformStride is only used when the stride is a unit-stride, i.e. in a
plain wide vector load. This tightens the condition and renames it to
isUnitStride. It removes the old unused getUniformStrided() variant, as
isUnitStride should now imply that the stride is known.

Reviewed By: vdmitrie, ABataev

Differential Revision: https://reviews.llvm.org/D150662




More information about the All-commits mailing list