[all-commits] [llvm/llvm-project] 7d3286: [hwasan] Use GetBlockBegin instead of GetBlockBegi...

Vitaly Buka via All-commits all-commits at lists.llvm.org
Wed Apr 5 16:18:06 PDT 2023


  Branch: refs/heads/main
  Home:   https://github.com/llvm/llvm-project
  Commit: 7d328668691afc32402a7e3c4ce2efb5547be2b2
      https://github.com/llvm/llvm-project/commit/7d328668691afc32402a7e3c4ce2efb5547be2b2
  Author: Vitaly Buka <vitalybuka at google.com>
  Date:   2023-04-05 (Wed, 05 Apr 2023)

  Changed paths:
    M compiler-rt/lib/hwasan/hwasan_allocator.cpp

  Log Message:
  -----------
  [hwasan] Use GetBlockBegin instead of GetBlockBeginFastLocked

Asan and lsan use non-locked version as well.
IgnoreObjectLocked name is missleading.


  Commit: 39c0602414d4b0efb1e4749b0e9fdd7974026bf7
      https://github.com/llvm/llvm-project/commit/39c0602414d4b0efb1e4749b0e9fdd7974026bf7
  Author: Vitaly Buka <vitalybuka at google.com>
  Date:   2023-04-05 (Wed, 05 Apr 2023)

  Changed paths:
    M compiler-rt/lib/asan/asan_allocator.cpp
    M compiler-rt/lib/hwasan/hwasan_allocator.cpp
    M compiler-rt/lib/lsan/lsan_allocator.cpp
    M compiler-rt/lib/lsan/lsan_common.cpp
    M compiler-rt/lib/lsan/lsan_common.h

  Log Message:
  -----------
  [lsan] Rename IgnoreObjectLocked into IgnoreObject

We don't lock allocator for this call.


Compare: https://github.com/llvm/llvm-project/compare/bf94afa10e51...39c0602414d4


More information about the All-commits mailing list