[all-commits] [llvm/llvm-project] 042107: [DebugInfo][NFC] Rename is/setUndef to is/setKilll...
Orlando Cazalet-Hyams via All-commits
all-commits at lists.llvm.org
Fri Jan 6 01:16:24 PST 2023
Branch: refs/heads/main
Home: https://github.com/llvm/llvm-project
Commit: 042107494d341f0e6eb38b474ec8bed13b6fd978
https://github.com/llvm/llvm-project/commit/042107494d341f0e6eb38b474ec8bed13b6fd978
Author: OCHyams <orlando.hyams at sony.com>
Date: 2023-01-06 (Fri, 06 Jan 2023)
Changed paths:
M llvm/include/llvm/IR/IntrinsicInst.h
M llvm/lib/CodeGen/AssignmentTrackingAnalysis.cpp
M llvm/lib/CodeGen/CodeGenPrepare.cpp
M llvm/lib/Transforms/Scalar/LoopStrengthReduce.cpp
M llvm/lib/Transforms/Utils/BasicBlockUtils.cpp
M llvm/lib/Transforms/Utils/Debugify.cpp
M llvm/lib/Transforms/Utils/LoopUtils.cpp
M llvm/unittests/Transforms/Utils/LocalTest.cpp
Log Message:
-----------
[DebugInfo][NFC] Rename is/setUndef to is/setKilllocation
These names better reflect the semantics and also the implementation, since
it's not just "undef" operands that are sentinels used to signal that the debug
intrinsic terminates dominating locations definitions.
Related to https://discourse.llvm.org/t/auto-undef-debug-uses-of-a-deleted-value
Reviewed By: StephenTozer
Differential Revision: https://reviews.llvm.org/D140903
More information about the All-commits
mailing list