[all-commits] [llvm/llvm-project] 84fc2c: [libc++] Make the naming of private member variabl...

philnik777 via All-commits all-commits at lists.llvm.org
Fri Sep 2 12:36:54 PDT 2022


  Branch: refs/heads/main
  Home:   https://github.com/llvm/llvm-project
  Commit: 84fc2c3cd62ab5be51d65f818854bb031b74c0f2
      https://github.com/llvm/llvm-project/commit/84fc2c3cd62ab5be51d65f818854bb031b74c0f2
  Author: Nikolas Klauser <nikolasklauser at berlin.de>
  Date:   2022-09-02 (Fri, 02 Sep 2022)

  Changed paths:
    M libcxx/.clang-tidy
    M libcxx/include/__algorithm/shuffle.h
    M libcxx/include/__algorithm/uniform_random_bit_generator_adaptor.h
    M libcxx/include/__chrono/day.h
    M libcxx/include/__chrono/hh_mm_ss.h
    M libcxx/include/__chrono/month.h
    M libcxx/include/__chrono/month_weekday.h
    M libcxx/include/__chrono/monthday.h
    M libcxx/include/__chrono/weekday.h
    M libcxx/include/__chrono/year.h
    M libcxx/include/__chrono/year_month.h
    M libcxx/include/__chrono/year_month_day.h
    M libcxx/include/__chrono/year_month_weekday.h
    M libcxx/include/__iterator/reverse_iterator.h
    M libcxx/include/__iterator/wrap_iter.h
    M libcxx/include/__locale
    M libcxx/include/__memory/shared_ptr.h
    M libcxx/include/__random/normal_distribution.h
    M libcxx/include/__random/shuffle_order_engine.h
    M libcxx/include/__support/win32/locale_win32.h
    M libcxx/include/any
    M libcxx/include/barrier
    M libcxx/include/codecvt
    M libcxx/include/exception
    M libcxx/include/experimental/functional
    M libcxx/include/experimental/iterator
    M libcxx/include/latch
    M libcxx/include/map
    M libcxx/include/semaphore
    M libcxx/include/shared_mutex
    M libcxx/include/span
    M libcxx/include/string_view
    M libcxx/include/unordered_map
    M libcxx/include/variant
    M libcxx/src/locale.cpp
    M libcxx/src/memory.cpp
    M libcxx/src/shared_mutex.cpp

  Log Message:
  -----------
  [libc++] Make the naming of private member variables consistent and enforce it through readability-identifier-naming

Reviewed By: ldionne, #libc

Spies: aheejin, sstefan1, libcxx-commits

Differential Revision: https://reviews.llvm.org/D129386




More information about the All-commits mailing list