[all-commits] [llvm/llvm-project] 113b56: [lld][WebAssembly] Rename SymbolTable::getSymbols ...

Sam Clegg via All-commits all-commits at lists.llvm.org
Wed Aug 31 14:38:20 PDT 2022


  Branch: refs/heads/main
  Home:   https://github.com/llvm/llvm-project
  Commit: 113b5688297256c4c8c43733d511dd8493461fa5
      https://github.com/llvm/llvm-project/commit/113b5688297256c4c8c43733d511dd8493461fa5
  Author: Sam Clegg <sbc at chromium.org>
  Date:   2022-08-31 (Wed, 31 Aug 2022)

  Changed paths:
    M lld/wasm/Driver.cpp
    M lld/wasm/MarkLive.cpp
    M lld/wasm/SymbolTable.cpp
    M lld/wasm/SymbolTable.h
    M lld/wasm/SyntheticSections.cpp
    M lld/wasm/Writer.cpp

  Log Message:
  -----------
  [lld][WebAssembly] Rename SymbolTable::getSymbols to match ELF backend. NFC

The ELF backend originally used `getSymbols()` but went though a
sequence of changes that resulted in this method being called
`symbols()`.

d8f8abbd4a2823f223bd7bc56445541fb221b512 replaced `getSymbols()` with
`forEachSymbol`.

a2fc96441788fba1e4709d63677f34ed8e321dae replaced `forEachSymbol` with
`llvm::iterator_range`.

e9262edf0d11a907763098d8e101219ccd9c43e9 replaced `llvm::iterator_range`
with `symbols()`.

Differential Revision: https://reviews.llvm.org/D131284




More information about the All-commits mailing list