[all-commits] [llvm/llvm-project] 2cd4cd: [lld][ELF] Rename SymbolTable::symbols() to Symbol...

Sam Clegg via All-commits all-commits at lists.llvm.org
Fri Aug 19 14:56:28 PDT 2022

  Branch: refs/heads/main
  Home:   https://github.com/llvm/llvm-project
  Commit: 2cd4cd9a326fd918374ce9330fc3a4e2c642e1b0
  Author: Sam Clegg <sbc at chromium.org>
  Date:   2022-08-19 (Fri, 19 Aug 2022)

  Changed paths:
    M lld/ELF/Driver.cpp
    M lld/ELF/ICF.cpp
    M lld/ELF/LTO.cpp
    M lld/ELF/MarkLive.cpp
    M lld/ELF/Relocations.cpp
    M lld/ELF/SymbolTable.h
    M lld/ELF/Writer.cpp

  Log Message:
  [lld][ELF] Rename SymbolTable::symbols() to SymbolTable::getSymbols(). NFC

This change renames this method match its original name and the name
used in the wasm linker.

Back in d8f8abbd4a2823f223bd7bc56445541fb221b512 the ELF SymbolTable
method `getSymbols()` was replaced with `forEachSymbol`.

Then in a2fc96441788fba1e4709d63677f34ed8e321dae `forEachSymbol` was
replaced with a `llvm::iterator_range`.

Then in e9262edf0d11a907763098d8e101219ccd9c43e9 we came full circle
and the `llvm::iterator_range` was replaced with a `symbols()` accessor
that was identical the original `getSymbols()`.

`getSymbols` also matches the name used elsewhere in the ELF linker as
well as in both COFF and wasm backend (e.g. `InputFiles.h` and

Differential Revision: https://reviews.llvm.org/D130787

More information about the All-commits mailing list