[all-commits] [llvm/llvm-project] 507125: [libc++] Rename __libcpp_assertion_handler to __li...
Louis Dionne via All-commits
all-commits at lists.llvm.org
Fri Jul 29 10:53:00 PDT 2022
Branch: refs/heads/main
Home: https://github.com/llvm/llvm-project
Commit: 507125af3d0b953cb56bce2e5b8000249fe1ef53
https://github.com/llvm/llvm-project/commit/507125af3d0b953cb56bce2e5b8000249fe1ef53
Author: Louis Dionne <ldionne.2 at gmail.com>
Date: 2022-07-29 (Fri, 29 Jul 2022)
Changed paths:
M libcxx/docs/UsingLibcxx.rst
M libcxx/include/CMakeLists.txt
M libcxx/include/__assert
M libcxx/include/__availability
A libcxx/include/__verbose_abort
M libcxx/include/module.modulemap.in
M libcxx/lib/abi/CHANGELOG.TXT
M libcxx/lib/abi/arm64-apple-darwin.libcxxabi.v1.stable.exceptions.nonew.abilist
M libcxx/lib/abi/powerpc-ibm-aix.libcxxabi.v1.stable.exceptions.nonew.abilist
M libcxx/lib/abi/powerpc64-ibm-aix.libcxxabi.v1.stable.exceptions.nonew.abilist
M libcxx/lib/abi/x86_64-apple-darwin.libcxxabi.v1.stable.exceptions.nonew.abilist
M libcxx/lib/abi/x86_64-unknown-linux-gnu.libcxxabi.v1.stable.exceptions.nonew.abilist
M libcxx/lib/abi/x86_64-unknown-linux-gnu.libcxxabi.v1.stable.noexceptions.nonew.abilist
M libcxx/src/CMakeLists.txt
R libcxx/src/assert.cpp
A libcxx/src/verbose_abort.cpp
R libcxx/test/libcxx/assertions/customize_handler.backdeployment.pass.cpp
R libcxx/test/libcxx/assertions/customize_handler.pass.cpp
A libcxx/test/libcxx/assertions/customize_verbose_abort.backdeployment.pass.cpp
A libcxx/test/libcxx/assertions/customize_verbose_abort.pass.cpp
M libcxx/test/libcxx/assertions/debug_mode_compatibility.pass.cpp
R libcxx/test/libcxx/assertions/default_handler.abort.pass.cpp
R libcxx/test/libcxx/assertions/default_handler.availability.verify.cpp
A libcxx/test/libcxx/assertions/default_verbose_abort.availability.verify.cpp
A libcxx/test/libcxx/assertions/default_verbose_abort.pass.cpp
R libcxx/test/libcxx/assertions/headers_declare_assertion_handler.sh.cpp
A libcxx/test/libcxx/assertions/headers_declare_verbose_abort.sh.cpp
M libcxx/test/support/check_assertion.h
M libcxx/utils/generate_header_tests.py
Log Message:
-----------
[libc++] Rename __libcpp_assertion_handler to __libcpp_verbose_abort
With the goal of reusing that handler to do other things besides
handling assertions (such as terminating when an exception is thrown
under -fno-exceptions), the name `__libcpp_assertion_handler` doesn't
really make sense anymore.
Furthermore, I didn't want to use the name `__libcpp_abort_handler`,
since that would give the impression that the handler is called
whenever `std::abort()` is called, which is not the case at all.
Differential Revision: https://reviews.llvm.org/D130562
More information about the All-commits
mailing list