[all-commits] [llvm/llvm-project] d27d0a: [Libomptarget][NFC] Make Libomptarget use the LLVM...

Joseph Huber via All-commits all-commits at lists.llvm.org
Tue Jul 5 11:53:54 PDT 2022


  Branch: refs/heads/main
  Home:   https://github.com/llvm/llvm-project
  Commit: d27d0a673c64068c5f3a1981c428e0ef5cff8062
      https://github.com/llvm/llvm-project/commit/d27d0a673c64068c5f3a1981c428e0ef5cff8062
  Author: Joseph Huber <jhuber6 at vols.utk.edu>
  Date:   2022-07-05 (Tue, 05 Jul 2022)

  Changed paths:
    M openmp/libomptarget/include/device.h
    M openmp/libomptarget/include/omptarget.h
    M openmp/libomptarget/include/omptargetplugin.h
    M openmp/libomptarget/include/rtl.h
    M openmp/libomptarget/plugins/amdgpu/src/rtl.cpp
    M openmp/libomptarget/plugins/common/elf_common/elf_common.cpp
    M openmp/libomptarget/plugins/common/elf_common/elf_common.h
    M openmp/libomptarget/plugins/cuda/src/rtl.cpp
    M openmp/libomptarget/plugins/generic-elf-64bit/src/rtl.cpp
    M openmp/libomptarget/src/api.cpp
    M openmp/libomptarget/src/device.cpp
    M openmp/libomptarget/src/interface.cpp
    M openmp/libomptarget/src/interop.cpp
    M openmp/libomptarget/src/omptarget.cpp
    M openmp/libomptarget/src/private.h
    M openmp/libomptarget/src/rtl.cpp

  Log Message:
  -----------
  [Libomptarget][NFC] Make Libomptarget use the LLVM naming convention

Libomptarget grew out of a project that was originally not in LLVM. As
we develop libomptarget this has led to an increasingly large clash
between the naming conventions used. This patch fixes most of the
variable names that did not confrom to the LLVM standard, that is
`VariableName` for variables and `functionName` for functions.

This patch was primarily done using my editor's linting messages, if
there are any issues I missed arising from the automation let me know.

Reviewed By: saiislam

Differential Revision: https://reviews.llvm.org/D128997




More information about the All-commits mailing list