[all-commits] [llvm/llvm-project] 78b0f3: [HIPSPV][1/4] Refactor HIP tool chain
Yaxun (Sam) Liu via All-commits
all-commits at lists.llvm.org
Mon Dec 13 07:51:00 PST 2021
Branch: refs/heads/main
Home: https://github.com/llvm/llvm-project
Commit: 78b0f3701d441e887e92ff9feec4c226c67c334f
https://github.com/llvm/llvm-project/commit/78b0f3701d441e887e92ff9feec4c226c67c334f
Author: Yaxun (Sam) Liu <yaxun.liu at amd.com>
Date: 2021-12-13 (Mon, 13 Dec 2021)
Changed paths:
M clang/lib/Driver/CMakeLists.txt
M clang/lib/Driver/Driver.cpp
M clang/lib/Driver/ToolChains/Clang.cpp
M clang/lib/Driver/ToolChains/CommonArgs.cpp
R clang/lib/Driver/ToolChains/HIP.cpp
R clang/lib/Driver/ToolChains/HIP.h
A clang/lib/Driver/ToolChains/HIPAMD.cpp
A clang/lib/Driver/ToolChains/HIPAMD.h
A clang/lib/Driver/ToolChains/HIPUtility.cpp
A clang/lib/Driver/ToolChains/HIPUtility.h
Log Message:
-----------
[HIPSPV][1/4] Refactor HIP tool chain
This patch refactors the HIP tool chain for new HIP tool chain, HIPSPV
tool chain, which is added in the follow up patch part 2.
Rename HIPToolChain to HIPAMDToolChain and Renames HIP.* files to HIPAMD.*.
Introduce HIPUtility.* file where common HIP utilities, shared among HIP
tool chain implementations, are placed in.
Move constructHIPFatbinCommand() and
constructGenerateObjFileFromHIPFatBinary() to HIPUtility. HIPSPV tool
chain is going to use them.
Tweak bundle target ID in constructHIPFatbinCommand(): extra dashes are
dropped if the Target ID is empty and 'hip' offload kind is made default
for non-AMD targets.
Patch by: Henry Linjamäki
Reviewed by: Yaxun Liu, Artem Belevich, Eric Christopher
Differential Revision: https://reviews.llvm.org/D110549
More information about the All-commits
mailing list