[all-commits] [llvm/llvm-project] ff569e: [lldb] [Utility/UriParser] Replace port==-1 with l...

Michał Górny via All-commits all-commits at lists.llvm.org
Fri Oct 22 05:39:32 PDT 2021


  Branch: refs/heads/main
  Home:   https://github.com/llvm/llvm-project
  Commit: ff569ed03092dba39effcc45e81d64beff800bb5
      https://github.com/llvm/llvm-project/commit/ff569ed03092dba39effcc45e81d64beff800bb5
  Author: Michał Górny <mgorny at moritz.systems>
  Date:   2021-10-22 (Fri, 22 Oct 2021)

  Changed paths:
    M lldb/include/lldb/Utility/UriParser.h
    M lldb/source/Plugins/Platform/Android/PlatformAndroid.cpp
    M lldb/source/Plugins/Platform/Android/PlatformAndroidRemoteGDBServer.cpp
    M lldb/source/Plugins/Platform/gdb-server/PlatformRemoteGDBServer.cpp
    M lldb/source/Plugins/Process/gdb-remote/GDBRemoteCommunicationServerLLGS.cpp
    M lldb/source/Plugins/Process/gdb-remote/GDBRemoteCommunicationServerPlatform.cpp
    M lldb/source/Utility/UriParser.cpp
    M lldb/tools/lldb-server/Acceptor.cpp
    M lldb/unittests/Host/ConnectionFileDescriptorTest.cpp
    M lldb/unittests/Host/SocketTest.cpp
    M lldb/unittests/Utility/UriParserTest.cpp

  Log Message:
  -----------
  [lldb] [Utility/UriParser] Replace port==-1 with llvm::None

Use llvm::Optional<uint16_t> instead of int for port number
in UriParser::Parse(), and use llvm::None to indicate missing port
instead of a magic value of -1.

Differential Revision: https://reviews.llvm.org/D112309




More information about the All-commits mailing list