[all-commits] [llvm/llvm-project] 8bac18: [lldb] Reduce code duplication around inferior bui...
Pavel Labath via All-commits
all-commits at lists.llvm.org
Tue Oct 19 03:10:03 PDT 2021
Branch: refs/heads/main
Home: https://github.com/llvm/llvm-project
Commit: 8bac18be0e45adc7b096375bf4f65635fb994df0
https://github.com/llvm/llvm-project/commit/8bac18be0e45adc7b096375bf4f65635fb994df0
Author: Pavel Labath <pavel at labath.sk>
Date: 2021-10-19 (Tue, 19 Oct 2021)
Changed paths:
M lldb/docs/testsuite/a-detailed-walkthrough.txt
M lldb/packages/Python/lldbsuite/test/README-TestSuite
M lldb/packages/Python/lldbsuite/test/builders/builder.py
M lldb/packages/Python/lldbsuite/test/builders/darwin.py
M lldb/packages/Python/lldbsuite/test/lldbtest.py
M lldb/packages/Python/lldbsuite/test/tools/lldb-server/gdbremote_testcase.py
M lldb/test/API/commands/add-dsym/uuid/TestAddDsymCommand.py
M lldb/test/API/functionalities/breakpoint/comp_dir_symlink/TestCompDirSymLink.py
M lldb/test/API/macosx/add-dsym/TestAddDsymDownload.py
M lldb/test/API/macosx/add-dsym/TestAddDsymMidExecutionCommand.py
Log Message:
-----------
[lldb] Reduce code duplication around inferior building
We had two sets of build<flavour> methods, whose bodies were largely
identical. This makes any kind of modification in their vicinity
repetitive and error-prone.
Replace each set with a single method taking an optional debug_info
parameter.
Differential Revision: https://reviews.llvm.org/D111989
More information about the All-commits
mailing list