[all-commits] [llvm/llvm-project] 8567f4: [lldb] Support querying registers via generic name...

Michał Górny via All-commits all-commits at lists.llvm.org
Mon Sep 13 04:05:20 PDT 2021


  Branch: refs/heads/main
  Home:   https://github.com/llvm/llvm-project
  Commit: 8567f4d4b9a79f041406026011fb8151b24b8c99
      https://github.com/llvm/llvm-project/commit/8567f4d4b9a79f041406026011fb8151b24b8c99
  Author: Michał Górny <mgorny at moritz.systems>
  Date:   2021-09-13 (Mon, 13 Sep 2021)

  Changed paths:
    M lldb/include/lldb/Core/ValueObjectRegister.h
    M lldb/source/API/SBFrame.cpp
    M lldb/source/Core/ValueObjectRegister.cpp
    M lldb/source/Host/common/NativeRegisterContext.cpp
    M lldb/source/Target/RegisterContext.cpp
    A lldb/test/API/functionalities/gdb_remote_client/TestGDBServerTargetXML.py

  Log Message:
  -----------
  [lldb] Support querying registers via generic names without alt_names

Update GetRegisterInfoByName() methods to support getting registers
by a generic name independently of alt_name entries in the register
context.  This makes it possible to use generic names when interacting
with gdbserver (that does not supply alt_names).  It also makes it
possible to remove some of the duplicated information from register
context declarations and/or use alt_names for another purpose.

Differential Revision: https://reviews.llvm.org/D108554


  Commit: e3d878bdd82e10658e7b31dc6adec4a582ba1891
      https://github.com/llvm/llvm-project/commit/e3d878bdd82e10658e7b31dc6adec4a582ba1891
  Author: Michał Górny <mgorny at moritz.systems>
  Date:   2021-09-13 (Mon, 13 Sep 2021)

  Changed paths:
    M lldb/source/Plugins/ABI/ARM/ABIMacOSX_arm.cpp
    M lldb/source/Plugins/ABI/ARM/ABISysV_arm.cpp
    M lldb/source/Plugins/ABI/Mips/ABISysV_mips.cpp
    M lldb/source/Plugins/ABI/Mips/ABISysV_mips64.cpp
    M lldb/source/Plugins/ABI/PowerPC/ABISysV_ppc.cpp
    M lldb/source/Plugins/ABI/SystemZ/ABISysV_s390x.cpp
    M lldb/source/Plugins/Process/Utility/RegisterContextWindows_x86_64.cpp
    M lldb/source/Plugins/Process/Utility/RegisterInfos_powerpc.h
    M lldb/source/Plugins/Process/Utility/RegisterInfos_ppc64.h
    M lldb/source/Plugins/Process/Utility/RegisterInfos_ppc64le.h
    M lldb/source/Plugins/Process/Utility/RegisterInfos_s390x.h
    M lldb/source/Plugins/Process/Utility/RegisterInfos_x86_64.h
    M lldb/source/Plugins/Process/gdb-remote/GDBRemoteRegisterContext.cpp

  Log Message:
  -----------
  [lldb] Remove redundant register alt_names

Remove redundant register alt_names that correspond to their respective
generic names.  D108554 makes it possible to query registers through
their generic names directly, therefore making repeating them via
alt_name unnecessary.

While at it, also remove alt_names that are equal to register names
on PPC.

This patch does not alter register definitions where the generic names
are listed as primary names, and other names are provided as alt_name
(e.g. ARM).

Differential Revision: https://reviews.llvm.org/D109626


Compare: https://github.com/llvm/llvm-project/compare/1d771e19fd1a...e3d878bdd82e


More information about the All-commits mailing list