[all-commits] [llvm/llvm-project] 916cdc: [NFC][X86] combineX86ShuffleChain(): rename inner ...

Roman Lebedev via All-commits all-commits at lists.llvm.org
Wed Aug 4 07:15:47 PDT 2021


  Branch: refs/heads/main
  Home:   https://github.com/llvm/llvm-project
  Commit: 916cdc3d4b66cf9658280cccb69a56eb6b403cdf
      https://github.com/llvm/llvm-project/commit/916cdc3d4b66cf9658280cccb69a56eb6b403cdf
  Author: Roman Lebedev <lebedev.ri at gmail.com>
  Date:   2021-08-04 (Wed, 04 Aug 2021)

  Changed paths:
    M llvm/lib/Target/X86/X86ISelLowering.cpp

  Log Message:
  -----------
  [NFC][X86] combineX86ShuffleChain(): rename inner Mask to avoid future shadowing

I want to hoist `Mask` variable higher up,
but then it would clash with this one.
So let's rename this one first.

There are no other intentional changes here other than said rename.


  Commit: 35c0848b570214ed2b2d96cca4dd62bb7ae725cd
      https://github.com/llvm/llvm-project/commit/35c0848b570214ed2b2d96cca4dd62bb7ae725cd
  Author: Roman Lebedev <lebedev.ri at gmail.com>
  Date:   2021-08-04 (Wed, 04 Aug 2021)

  Changed paths:
    M llvm/lib/Target/X86/X86ISelLowering.cpp

  Log Message:
  -----------
  [NFC][X86] combineX86ShuffleChain(): hoist Mask variable higher up

Having `NewMask` outside of an if and rebinding `BaseMask` `ArrayRef`
to it is confusing. Instead, just move the `Mask` vector higher up,
and change the code that earlier had no access to it but now does
to use `Mask` instead of `BaseMask`.

This has no other intentional changes.


Compare: https://github.com/llvm/llvm-project/compare/40650f27b5df...35c0848b5702


More information about the All-commits mailing list