[all-commits] [llvm/llvm-project] cf4f52: [AMDGPU] SIFoldOperands: use getVRegDef instead of...
Jay Foad via All-commits
all-commits at lists.llvm.org
Tue Apr 6 07:24:22 PDT 2021
Branch: refs/heads/main
Home: https://github.com/llvm/llvm-project
Commit: cf4f5292f637d4ff1217da67d07147d63257ca87
https://github.com/llvm/llvm-project/commit/cf4f5292f637d4ff1217da67d07147d63257ca87
Author: Jay Foad <jay.foad at amd.com>
Date: 2021-04-06 (Tue, 06 Apr 2021)
Changed paths:
M llvm/lib/Target/AMDGPU/SIFoldOperands.cpp
Log Message:
-----------
[AMDGPU] SIFoldOperands: use getVRegDef instead of getUniqueVRegDef
We are in SSA so getVRegDef is equivalent but simpler. NFC.
Commit: ce9cca6c3a31998b924ac9c67d8e1c70ada5665b
https://github.com/llvm/llvm-project/commit/ce9cca6c3a31998b924ac9c67d8e1c70ada5665b
Author: Jay Foad <jay.foad at amd.com>
Date: 2021-04-06 (Tue, 06 Apr 2021)
Changed paths:
M llvm/lib/Target/AMDGPU/SIFoldOperands.cpp
Log Message:
-----------
[AMDGPU] SIFoldOperands: rename tryFoldInst to tryFoldCndMask
This follows the pattern of the other tryFold* functions. NFC.
Commit: 005dcd196ef64f77cc3070ed3a2df6ba6e78c628
https://github.com/llvm/llvm-project/commit/005dcd196ef64f77cc3070ed3a2df6ba6e78c628
Author: Jay Foad <jay.foad at amd.com>
Date: 2021-04-06 (Tue, 06 Apr 2021)
Changed paths:
M llvm/lib/Target/AMDGPU/SIFoldOperands.cpp
Log Message:
-----------
[AMDGPU] SIFoldOperands: use range-based loops and make_early_inc_range
NFC.
Commit: efc7bf27f5ee87ac106c6e48c4276e26f4f04715
https://github.com/llvm/llvm-project/commit/efc7bf27f5ee87ac106c6e48c4276e26f4f04715
Author: Jay Foad <jay.foad at amd.com>
Date: 2021-04-06 (Tue, 06 Apr 2021)
Changed paths:
M llvm/lib/Target/AMDGPU/SIFoldOperands.cpp
Log Message:
-----------
[AMDGPU] SIFoldOperands: use MachineRegisterInfo::hasOneNonDBGUser
NFC.
Compare: https://github.com/llvm/llvm-project/compare/ccb361af6cf7...efc7bf27f5ee
More information about the All-commits
mailing list