[all-commits] [llvm/llvm-project] 29812a: [MLIR][SPIRV] Rename `spv.loop` to `spv.mlir.loop`.
Kareem Ergawy via All-commits
all-commits at lists.llvm.org
Fri Mar 5 12:44:49 PST 2021
Branch: refs/heads/main
Home: https://github.com/llvm/llvm-project
Commit: 29812a6195f9bb3501c5d323a87e1c1926797979
https://github.com/llvm/llvm-project/commit/29812a6195f9bb3501c5d323a87e1c1926797979
Author: KareemErgawy-TomTom <kareem.ergawy at gmail.com>
Date: 2021-03-05 (Fri, 05 Mar 2021)
Changed paths:
M mlir/docs/Dialects/SPIR-V.md
M mlir/docs/SPIRVToLLVMDialectConversion.md
M mlir/include/mlir/Dialect/SPIRV/IR/SPIRVControlFlowOps.td
M mlir/lib/Conversion/SCFToSPIRV/SCFToSPIRV.cpp
M mlir/lib/Conversion/SPIRVToLLVM/SPIRVToLLVM.cpp
M mlir/lib/Dialect/SPIRV/IR/SPIRVDialect.cpp
M mlir/lib/Dialect/SPIRV/IR/SPIRVOps.cpp
M mlir/lib/Target/SPIRV/Deserialization/Deserializer.cpp
M mlir/lib/Target/SPIRV/Deserialization/Deserializer.h
M mlir/lib/Target/SPIRV/Serialization/Serializer.cpp
M mlir/test/Conversion/SCFToSPIRV/for.mlir
M mlir/test/Conversion/SPIRVToLLVM/control-flow-ops-to-llvm.mlir
M mlir/test/Dialect/SPIRV/IR/control-flow-ops.mlir
M mlir/test/Dialect/SPIRV/Transforms/inlining.mlir
M mlir/test/Target/SPIRV/debug.mlir
M mlir/test/Target/SPIRV/function-call.mlir
M mlir/test/Target/SPIRV/loop.mlir
M mlir/test/Target/SPIRV/phi.mlir
Log Message:
-----------
[MLIR][SPIRV] Rename `spv.loop` to `spv.mlir.loop`.
To unify the naming scheme across all ops in the SPIR-V dialect,
we are moving from spv.camelCase to spv.CamelCase everywhere.
Reviewed By: antiagainst
Differential Revision: https://reviews.llvm.org/D97918
More information about the All-commits
mailing list