[all-commits] [llvm/llvm-project] c74eb4: [MLIR][SPIRV] Rename `spv.globalVariable` to `spv....
Kareem Ergawy via All-commits
all-commits at lists.llvm.org
Thu Mar 4 13:25:21 PST 2021
Branch: refs/heads/main
Home: https://github.com/llvm/llvm-project
Commit: c74eb466d22997828e1d3ce5f4f7c38282525544
https://github.com/llvm/llvm-project/commit/c74eb466d22997828e1d3ce5f4f7c38282525544
Author: KareemErgawy-TomTom <kareem.ergawy at gmail.com>
Date: 2021-03-04 (Thu, 04 Mar 2021)
Changed paths:
M mlir/docs/Dialects/SPIR-V.md
M mlir/docs/SPIRVToLLVMDialectConversion.md
M mlir/include/mlir/Dialect/SPIRV/IR/SPIRVStructureOps.td
M mlir/include/mlir/Dialect/SPIRV/Linking/ModuleCombiner.h
M mlir/lib/Conversion/SPIRVToLLVM/ConvertLaunchFuncToLLVMCalls.cpp
M mlir/lib/Conversion/SPIRVToLLVM/SPIRVToLLVM.cpp
M mlir/lib/Conversion/StandardToSPIRV/StandardToSPIRV.cpp
M mlir/lib/Dialect/SPIRV/IR/SPIRVOps.cpp
M mlir/lib/Dialect/SPIRV/Transforms/SPIRVConversion.cpp
M mlir/lib/Target/SPIRV/Deserialization/Deserializer.h
M mlir/test/Conversion/GPUToSPIRV/builtins.mlir
M mlir/test/Conversion/GPUToSPIRV/load-store.mlir
M mlir/test/Conversion/GPUToVulkan/lower-gpu-launch-vulkan-launch.mlir
M mlir/test/Conversion/LinalgToSPIRV/linalg-to-spirv.mlir
M mlir/test/Conversion/SPIRVToLLVM/lower-host-to-llvm-calls.mlir
M mlir/test/Conversion/SPIRVToLLVM/memory-ops-to-llvm.mlir
M mlir/test/Conversion/StandardToSPIRV/alloc.mlir
M mlir/test/Dialect/SPIRV/IR/memory-ops.mlir
M mlir/test/Dialect/SPIRV/IR/structure-ops.mlir
M mlir/test/Dialect/SPIRV/Linking/ModuleCombiner/conflict-resolution.mlir
M mlir/test/Dialect/SPIRV/Linking/ModuleCombiner/deduplication.mlir
M mlir/test/Dialect/SPIRV/Transforms/abi-interface.mlir
M mlir/test/Dialect/SPIRV/Transforms/abi-load-store.mlir
M mlir/test/Dialect/SPIRV/Transforms/inlining.mlir
M mlir/test/Dialect/SPIRV/Transforms/layout-decoration.mlir
M mlir/test/Dialect/SPIRV/Transforms/vce-deduction.mlir
M mlir/test/Target/SPIRV/array.mlir
M mlir/test/Target/SPIRV/debug.mlir
M mlir/test/Target/SPIRV/decorations.mlir
M mlir/test/Target/SPIRV/entry-point.mlir
M mlir/test/Target/SPIRV/function-call.mlir
M mlir/test/Target/SPIRV/global-variable.mlir
M mlir/test/Target/SPIRV/image.mlir
M mlir/test/Target/SPIRV/loop.mlir
M mlir/test/Target/SPIRV/matrix.mlir
M mlir/test/Target/SPIRV/phi.mlir
M mlir/test/Target/SPIRV/sampled-image.mlir
M mlir/test/Target/SPIRV/struct.mlir
Log Message:
-----------
[MLIR][SPIRV] Rename `spv.globalVariable` to `spv.GlobalVariable`.
To unify the naming scheme across all ops in the SPIR-V dialect, we are
moving from spv.camelCase to spv.CamelCase everywhere.
Reviewed By: antiagainst
Differential Revision: https://reviews.llvm.org/D97919
More information about the All-commits
mailing list