[all-commits] [llvm/llvm-project] 37eca0: [mlir][NFC] Rename `MemRefType::getMemorySpace` to...
Vladislav Vinogradov via All-commits
all-commits at lists.llvm.org
Tue Mar 2 00:19:54 PST 2021
Branch: refs/heads/main
Home: https://github.com/llvm/llvm-project
Commit: 37eca08e5bcfbe926176412a4a0acf5b963da7e6
https://github.com/llvm/llvm-project/commit/37eca08e5bcfbe926176412a4a0acf5b963da7e6
Author: Vladislav Vinogradov <vlad.vinogradov at intel.com>
Date: 2021-03-02 (Tue, 02 Mar 2021)
Changed paths:
M mlir/include/mlir/Dialect/Affine/IR/AffineOps.h
M mlir/include/mlir/Dialect/StandardOps/IR/Ops.h
M mlir/include/mlir/IR/BuiltinTypes.h
M mlir/lib/CAPI/IR/BuiltinTypes.cpp
M mlir/lib/Conversion/GPUToNVVM/LowerGpuOpsToNVVMOps.cpp
M mlir/lib/Conversion/StandardToLLVM/StandardToLLVM.cpp
M mlir/lib/Conversion/StandardToSPIRV/StandardToSPIRV.cpp
M mlir/lib/Conversion/VectorToLLVM/ConvertVectorToLLVM.cpp
M mlir/lib/Conversion/VectorToROCDL/VectorToROCDL.cpp
M mlir/lib/Conversion/VectorToSCF/VectorToSCF.cpp
M mlir/lib/Dialect/GPU/IR/GPUDialect.cpp
M mlir/lib/Dialect/LLVMIR/IR/LLVMDialect.cpp
M mlir/lib/Dialect/SPIRV/Transforms/SPIRVConversion.cpp
M mlir/lib/Dialect/StandardOps/IR/Ops.cpp
M mlir/lib/Dialect/Vector/VectorOps.cpp
M mlir/lib/IR/AsmPrinter.cpp
M mlir/lib/IR/BuiltinTypes.cpp
M mlir/lib/Transforms/LoopFusion.cpp
M mlir/lib/Transforms/Utils/LoopUtils.cpp
Log Message:
-----------
[mlir][NFC] Rename `MemRefType::getMemorySpace` to `getMemorySpaceAsInt`
Just a pure method renaming.
It is a preparation step for replacing "memory space as raw integer"
with more generic "memory space as attribute", which will be done in
separate commit.
The `MemRefType::getMemorySpace` method will return `Attribute` and
become the main API, while `getMemorySpaceAsInt` will be declared as
deprecated and will be replaced in all in-tree dialects (also in separate
commits).
Reviewed By: mehdi_amini, rriddle
Differential Revision: https://reviews.llvm.org/D97476
More information about the All-commits
mailing list