[all-commits] [llvm/llvm-project] 14ffbb: [lld][WebAssembly] Rename methods/members to match...

Sam Clegg via All-commits all-commits at lists.llvm.org
Fri Feb 26 17:08:48 PST 2021


  Branch: refs/heads/main
  Home:   https://github.com/llvm/llvm-project
  Commit: 14ffbb84aa45ddc22a564074fb2e32e8cef6c586
      https://github.com/llvm/llvm-project/commit/14ffbb84aa45ddc22a564074fb2e32e8cef6c586
  Author: Sam Clegg <sbc at chromium.org>
  Date:   2021-02-26 (Fri, 26 Feb 2021)

  Changed paths:
    M lld/wasm/InputChunks.cpp
    M lld/wasm/InputChunks.h
    M lld/wasm/InputFiles.cpp
    M lld/wasm/MapFile.cpp
    M lld/wasm/OutputSections.cpp
    M lld/wasm/SymbolTable.cpp
    M lld/wasm/Symbols.cpp
    M lld/wasm/Symbols.h
    M lld/wasm/SyntheticSections.cpp
    M lld/wasm/Writer.cpp

  Log Message:
  -----------
  [lld][WebAssembly] Rename methods/members to match ELF backend. NFC.

Specifically:

- InputChunk::outputOffset -> outSecOffset
- Symbol::get/setVirtualAddress -> get/setVA
- add InputChunk::getOffset helper that takes an offset

These are mostly in preparation for adding support for
SHF_MERGE/SHF_STRINGS but its also good to align with ELF where
possible.

Differential Revision: https://reviews.llvm.org/D97595




More information about the All-commits mailing list