[all-commits] [llvm/llvm-project] 868d43: [InstCombine] add helper for x/pow(); NFC
RotateRight via All-commits
all-commits at lists.llvm.org
Wed Feb 24 13:44:57 PST 2021
Branch: refs/heads/main
Home: https://github.com/llvm/llvm-project
Commit: 868d43fbd6571d11f91564969676bb0f1b19b455
https://github.com/llvm/llvm-project/commit/868d43fbd6571d11f91564969676bb0f1b19b455
Author: Sanjay Patel <spatel at rotateright.com>
Date: 2021-02-24 (Wed, 24 Feb 2021)
Changed paths:
M llvm/lib/Transforms/InstCombine/InstCombineMulDivRem.cpp
Log Message:
-----------
[InstCombine] add helper for x/pow(); NFC
We at least want to add powi to this list, so
split it off into a switch to reduce code duplication.
Commit: a7cee55762c6564de9dfc90985fe5c14cad7f9ee
https://github.com/llvm/llvm-project/commit/a7cee55762c6564de9dfc90985fe5c14cad7f9ee
Author: Sanjay Patel <spatel at rotateright.com>
Date: 2021-02-24 (Wed, 24 Feb 2021)
Changed paths:
M llvm/lib/Transforms/InstCombine/InstCombineMulDivRem.cpp
M llvm/test/Transforms/InstCombine/fdiv.ll
Log Message:
-----------
[InstCombine] fold fdiv with powi divisor (PR49147)
This extends b40fde062c for the especially non-standard
powi pattern. We want to avoid being completely wrong
on the negation-of-int-min corner case, so I'm adding
an extra FMF check for 'ninf' assuming that gives us
the flexibility to handle that possibility.
https://llvm.org/PR49147
Compare: https://github.com/llvm/llvm-project/compare/80f329bcd028...a7cee55762c6
More information about the All-commits
mailing list