[all-commits] [llvm/llvm-project] 6728af: [mlir][vector] modified scatter/gather syntax, pas...

Aart Bik via All-commits all-commits at lists.llvm.org
Sat Jan 9 11:42:01 PST 2021


  Branch: refs/heads/main
  Home:   https://github.com/llvm/llvm-project
  Commit: 6728af16cf987df3cf051f3a1f9c92ed2b8fbc2d
      https://github.com/llvm/llvm-project/commit/6728af16cf987df3cf051f3a1f9c92ed2b8fbc2d
  Author: Aart Bik <ajcbik at google.com>
  Date:   2021-01-09 (Sat, 09 Jan 2021)

  Changed paths:
    M mlir/include/mlir/Dialect/Vector/VectorOps.td
    M mlir/integration_test/Dialect/Vector/CPU/test-gather.mlir
    M mlir/integration_test/Dialect/Vector/CPU/test-scatter.mlir
    M mlir/integration_test/Dialect/Vector/CPU/test-sparse-dot-matvec.mlir
    M mlir/integration_test/Dialect/Vector/CPU/test-sparse-saxpy-jagged-matvec.mlir
    M mlir/lib/Dialect/Vector/VectorOps.cpp
    M mlir/test/Conversion/VectorToLLVM/vector-to-llvm.mlir
    M mlir/test/Dialect/Vector/invalid.mlir
    M mlir/test/Dialect/Vector/ops.mlir
    M mlir/test/Dialect/Vector/vector-mem-transforms.mlir

  Log Message:
  -----------
  [mlir][vector] modified scatter/gather syntax, pass_thru mandatory

This change makes the scatter/gather syntax more consistent with
the syntax of all the other memory operations in the Vector dialect
(order of types, use of [] for index, etc.). This will make the MLIR
code easier to read. In addition, the pass_thru parameter of the
gather has been made mandatory (there is very little benefit in
using the implicit "undefined" values).

Reviewed By: nicolasvasilache

Differential Revision: https://reviews.llvm.org/D94352




More information about the All-commits mailing list