[all-commits] [llvm/llvm-project] 6bb912: DWARFYAML::emitDebugSections - fix use after std::...
Simon Pilgrim via All-commits
all-commits at lists.llvm.org
Sun Sep 20 07:22:27 PDT 2020
Branch: refs/heads/master
Home: https://github.com/llvm/llvm-project
Commit: 6bb912336804822cc4b09f6849f1fd7d12057132
https://github.com/llvm/llvm-project/commit/6bb912336804822cc4b09f6849f1fd7d12057132
Author: Simon Pilgrim <llvm-dev at redking.me.uk>
Date: 2020-09-20 (Sun, 20 Sep 2020)
Changed paths:
M llvm/lib/ObjectYAML/DWARFEmitter.cpp
Log Message:
-----------
DWARFYAML::emitDebugSections - fix use after std::move warnings. NFCI.
We were using Err after it had been moved into cantFail - avoid this by calling cantFail with Error::success() directly.
Commit: 2b634a9d0e144a619ba68fc064dab0771f725063
https://github.com/llvm/llvm-project/commit/2b634a9d0e144a619ba68fc064dab0771f725063
Author: Simon Pilgrim <llvm-dev at redking.me.uk>
Date: 2020-09-20 (Sun, 20 Sep 2020)
Changed paths:
M llvm/lib/Target/X86/X86ISelLowering.cpp
Log Message:
-----------
[X86] Rename getExtendInVec to getEXTEND_VECTOR_INREG. NFCI.
Make it easier to find the method by naming it after the ops it actually handles. We already do this for lowering/combining.
Compare: https://github.com/llvm/llvm-project/compare/91720ee561b2...2b634a9d0e14
More information about the All-commits
mailing list