[all-commits] [llvm/llvm-project] 2e92b3: [clang] Rename Decl::isHidden() to isUnconditional...
martinboehme via All-commits
all-commits at lists.llvm.org
Fri Jun 12 00:45:59 PDT 2020
Branch: refs/heads/master
Home: https://github.com/llvm/llvm-project
Commit: 2e92b397ae4bd846d34d151749ef09c1a1b81dab
https://github.com/llvm/llvm-project/commit/2e92b397ae4bd846d34d151749ef09c1a1b81dab
Author: Martin Boehme <mboehme at google.com>
Date: 2020-06-12 (Fri, 12 Jun 2020)
Changed paths:
M clang/include/clang/AST/DeclBase.h
M clang/include/clang/AST/DeclObjC.h
M clang/include/clang/Sema/Lookup.h
M clang/include/clang/Sema/Sema.h
M clang/lib/AST/ASTDumper.cpp
M clang/lib/AST/DeclObjC.cpp
M clang/lib/AST/JSONNodeDumper.cpp
M clang/lib/AST/TextNodeDumper.cpp
M clang/lib/Sema/SemaDeclObjC.cpp
M clang/lib/Sema/SemaLookup.cpp
M clang/lib/Serialization/ASTReader.cpp
M clang/lib/Serialization/ASTWriter.cpp
Log Message:
-----------
[clang] Rename Decl::isHidden() to isUnconditionallyVisible().
Also invert the sense of the return value.
As pointed out by the FIXME that this change resolves, isHidden() wasn't
a very accurate name for this function.
I haven't yet changed any of the strings that are output in
ASTDumper.cpp / JSONNodeDumper.cpp / TextNodeDumper.cpp in response to
whether isHidden() is set because
a) I'm not sure whether it's actually desired to change these strings
(would appreciate feedback on this), and
b) In any case, I'd like to get this pure rename out of the way first,
without any changes to tests. Changing the strings that are output in
the various ...Dumper.cpp files will require changes to quite a few
tests, and I'd like to make those in a separate change.
Differential Revision: https://reviews.llvm.org/D81392
Reviewed By: rsmith
More information about the All-commits
mailing list