[all-commits] [llvm/llvm-project] 835c2a: [MC] Reorganize and improve macro tests
Fangrui Song via All-commits
all-commits at lists.llvm.org
Sun Apr 12 22:54:47 PDT 2020
Branch: refs/heads/master
Home: https://github.com/llvm/llvm-project
Commit: 835c2aa7a68bb1fc559233e007f8e57b263eac99
https://github.com/llvm/llvm-project/commit/835c2aa7a68bb1fc559233e007f8e57b263eac99
Author: Fangrui Song <maskray at google.com>
Date: 2020-04-12 (Sun, 12 Apr 2020)
Changed paths:
M llvm/lib/MC/MCParser/AsmParser.cpp
A llvm/test/MC/AsmParser/altmacro-err.s
A llvm/test/MC/AsmParser/altmacro-expr-err.s
R llvm/test/MC/AsmParser/at-pseudo-variable-bad.s
R llvm/test/MC/AsmParser/at-pseudo-variable.s
R llvm/test/MC/AsmParser/bad-macro.s
R llvm/test/MC/AsmParser/inline_macro_duplication.ll
R llvm/test/MC/AsmParser/invalid-input-assertion.s
M llvm/test/MC/AsmParser/macro-arg-err.s
A llvm/test/MC/AsmParser/macro-at-pseudo-variable-err.s
A llvm/test/MC/AsmParser/macro-at-pseudo-variable.s
A llvm/test/MC/AsmParser/macro-same-context.ll
A llvm/test/MC/AsmParser/macro-vararg-err.s
A llvm/test/MC/AsmParser/macro-vararg.s
R llvm/test/MC/AsmParser/negativ_altmacro_expression.s
R llvm/test/MC/AsmParser/negative_altmacro_string.s
A llvm/test/MC/AsmParser/unmatched-if-macro.s
A llvm/test/MC/AsmParser/unmatched-if.s
R llvm/test/MC/AsmParser/vararg.s
Log Message:
-----------
[MC] Reorganize and improve macro tests
* Reorganize tests and add coverage
* Improve diagnostic testing
* Make assert() tests more relevant
* Rename tests to macro-* or altmacro-*
This is not NFC because a (previously untested) diagnostic message is changed.
More information about the All-commits
mailing list