[all-commits] [llvm/llvm-project] 546659: [NFC] Refactor InlineResult for readability
Mircea Trofin via All-commits
all-commits at lists.llvm.org
Wed Jan 15 13:47:16 PST 2020
Branch: refs/heads/master
Home: https://github.com/llvm/llvm-project
Commit: 5466597fee379b44f643cee0e0632fdef8fb6b21
https://github.com/llvm/llvm-project/commit/5466597fee379b44f643cee0e0632fdef8fb6b21
Author: Mircea Trofin <mtrofin at google.com>
Date: 2020-01-15 (Wed, 15 Jan 2020)
Changed paths:
M llvm/include/llvm/Analysis/InlineCost.h
M llvm/lib/Analysis/InlineCost.cpp
M llvm/lib/CodeGen/SafeStack.cpp
M llvm/lib/Target/AMDGPU/AMDGPUInline.cpp
M llvm/lib/Transforms/IPO/AlwaysInliner.cpp
M llvm/lib/Transforms/IPO/Inliner.cpp
M llvm/lib/Transforms/IPO/PartialInlining.cpp
M llvm/lib/Transforms/IPO/SampleProfile.cpp
M llvm/lib/Transforms/Scalar/PlaceSafepoints.cpp
M llvm/lib/Transforms/Utils/InlineFunction.cpp
Log Message:
-----------
[NFC] Refactor InlineResult for readability
Summary:
InlineResult is used both in APIs assessing whether a call site is
inlinable (e.g. llvm::isInlineViable) as well as in the function
inlining utility (llvm::InlineFunction). It means slightly different
things (can/should inlining happen, vs did it happen), and the
implicit casting may introduce ambiguity (casting from 'false' in
InlineFunction will default a message about hight costs,
which is incorrect here).
The change renames the type to a more generic name, and disables
implicit constructors.
Reviewers: eraman, davidxl
Reviewed By: davidxl
Subscribers: kerbowa, arsenm, jvesely, nhaehnle, eraman, hiraditya, haicheng, llvm-commits
Tags: #llvm
Differential Revision: https://reviews.llvm.org/D72744
More information about the All-commits
mailing list