[all-commits] [llvm/llvm-project] 3d41a5: [PowerPC][NFC] Rename ANDI(S)o8 to ANDI(S)8o

jsji via All-commits all-commits at lists.llvm.org
Mon Dec 9 11:23:43 PST 2019


  Branch: refs/heads/master
  Home:   https://github.com/llvm/llvm-project
  Commit: 3d41a58eac132e43576eb3463c922a45a4ceca34
      https://github.com/llvm/llvm-project/commit/3d41a58eac132e43576eb3463c922a45a4ceca34
  Author: Jinsong Ji <jji at us.ibm.com>
  Date:   2019-12-09 (Mon, 09 Dec 2019)

  Changed paths:
    M llvm/lib/Target/PowerPC/P9InstrResources.td
    M llvm/lib/Target/PowerPC/PPCISelDAGToDAG.cpp
    M llvm/lib/Target/PowerPC/PPCISelLowering.cpp
    M llvm/lib/Target/PowerPC/PPCInstr64Bit.td
    M llvm/lib/Target/PowerPC/PPCInstrInfo.cpp
    M llvm/lib/Target/PowerPC/PPCInstrVSX.td
    M llvm/lib/Target/PowerPC/PPCMIPeephole.cpp
    M llvm/test/CodeGen/PowerPC/convert-rr-to-ri-instrs-out-of-range.mir
    M llvm/test/CodeGen/PowerPC/convert-rr-to-ri-instrs.mir
    M llvm/test/CodeGen/PowerPC/ifcvt-diamond-ret.mir
    M llvm/test/CodeGen/PowerPC/opt-cmp-inst-cr0-live.ll
    M llvm/test/CodeGen/PowerPC/peephole-miscompile-extswsli.mir
    M llvm/test/CodeGen/PowerPC/rlwinm_rldicl_to_andi.mir

  Log Message:
  -----------
  [PowerPC][NFC] Rename ANDI(S)o8 to ANDI(S)8o

Summary:
This is found during https://reviews.llvm.org/D70758
All the other record forms are having suffix o at the end.
ANDIo8 and ANDISo8 are the only two that put o before 8.

This patch rename them to be consistent with others.

Reviewers: #powerpc, hfinkel, nemanjai, lei, steven.zhang, echristo, jhibbits, joerg

Reviewed By: jhibbits

Subscribers: wuzish, hiraditya, kbarton, shchenz, llvm-commits

Tags: #llvm

Differential Revision: https://reviews.llvm.org/D70928




More information about the All-commits mailing list