[all-commits] [llvm/llvm-project] 6749dc: [InstCombine] Don't transform bitcasts between x86...

topperc via All-commits all-commits at lists.llvm.org
Thu Nov 7 15:44:31 PST 2019


  Branch: refs/heads/master
  Home:   https://github.com/llvm/llvm-project
  Commit: 6749dc3446671df05235d0a218c426a314ac33cd
      https://github.com/llvm/llvm-project/commit/6749dc3446671df05235d0a218c426a314ac33cd
  Author: Craig Topper <craig.topper at intel.com>
  Date:   2019-11-07 (Thu, 07 Nov 2019)

  Changed paths:
    M llvm/lib/Transforms/InstCombine/InstCombineCasts.cpp
    M llvm/test/Transforms/InstCombine/bitcast-vec-canon.ll

  Log Message:
  -----------
  [InstCombine] Don't transform bitcasts between x86_mmx and v1i64 into insertelement/extractelement

x86_mmx is conceptually a vector already. Don't introduce an extra conversion between it and scalar i64.

I'm using VectorType::isValidElementType which checks for floating point, integer, and pointers to hopefully make this more readable than just blacklisting x86_mmx.

Differential Revision: https://reviews.llvm.org/D69964




More information about the All-commits mailing list