[Parallel_libs-commits] [PATCH] D24148: [StreamExecutor] Read dev array directly in test

Justin Lebar via Parallel_libs-commits parallel_libs-commits at lists.llvm.org
Thu Sep 1 12:10:11 PDT 2016


jlebar added inline comments.

================
Comment at: streamexecutor/lib/unittests/SimpleHostPlatformDevice.h:30
@@ -29,3 +29,3 @@
 /// std::memcpy.
 class SimpleHostPlatformDevice : public streamexecutor::PlatformDevice {
   std::string getName() const override { return "SimpleHostPlatformDevice"; }
----------------
Hm, I just noticed this whole file is in the global namespace.  Is that intentional?

================
Comment at: streamexecutor/lib/unittests/SimpleHostPlatformDevice.h:138
@@ +137,3 @@
+template <typename T>
+T getDeviceValue(const streamexecutor::GlobalDeviceMemory<T> &Memory,
+                 size_t Index) {
----------------
This seems like an awfully generic name...  I guess it's only for unit tests, but still...

It could be a static function on SimpleHostPlatformDevice?


https://reviews.llvm.org/D24148





More information about the Parallel_libs-commits mailing list