<div dir="ltr"><br><div class="gmail_extra"><br><div class="gmail_quote">On Thu, Oct 23, 2014 at 9:50 AM, Carlo Bertolli <span dir="ltr"><<a href="mailto:cbertol@us.ibm.com" target="_blank">cbertol@us.ibm.com</a>></span> wrote:<br><blockquote class="gmail_quote" style="margin:0px 0px 0px 0.8ex;border-left-width:1px;border-left-color:rgb(204,204,204);border-left-style:solid;padding-left:1ex"><div>
<p><font face="sans-serif">Hi all</font><br>
<br>
<font face="sans-serif">The following patch is to support the PPC64LE (little endian) architecture.</font><br>
<br>
<font face="sans-serif">Please note that in the source code I distinguished the two architectures with two different macros (KMP_ARCH_PPC64 and KMP_ARCH_PPC64LE).</font><br>
<font face="sans-serif">However, the two macros are currently always used together and the compilation path is precisely the same.</font><br>
<font face="sans-serif">I did this because I wanted to make sure that in the future we are able to distinguish them.</font><br>
<br>
<br>
<font face="sans-serif">Please let me know your thoughts.</font></p></div></blockquote><div><br></div><div>I don't think this is super important, but I would have done the following</div><div><br></div><div>KMP_ARCH_PPC64 == Things shared for both BE and LE<br></div><div>KMP_ARCH_PPC64BE == BE specific<br></div><div>KMP_ARCH_PPC64LE == LE specific<br></div><div><br></div><div>Currently in the patch I think you're using KMP_ARCH_PPC64 to mean BE, but in the future if anything is common to both of them will you just use KMP_ARCH_PPC64 || KMP_ARCH_PPC64LE or what's the plan? (They can't always be mutually exclusive - can they?)</div></div></div></div>