[Openmp-commits] [PATCH] D69423: [NFC] [libomptarget] Move option.h into target_impl.h, name a magic number

Alexey Bataev via Phabricator via Openmp-commits openmp-commits at lists.llvm.org
Fri Oct 25 10:06:57 PDT 2019


ABataev added inline comments.


================
Comment at: openmp/libomptarget/deviceRTLs/nvptx/src/target_impl.h:135-141
+INLINE uint32_t __kmpc_impl_get_warp_id() { return threadIdx.x / WARPSIZE; }
+
+INLINE uint32_t __kmpc_impl_get_thread_id_in_warp() {
+  int threadIdxMask = WARPSIZE - 1;
+  return threadIdx.x & threadIdxMask;
+}
+
----------------
Maybe, split this patch into 2 and introduce these functions and new processing of check functions in the new patch?


Repository:
  rG LLVM Github Monorepo

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D69423/new/

https://reviews.llvm.org/D69423





More information about the Openmp-commits mailing list