[Openmp-commits] [PATCH] D60972: [OpenMP 5.0] libomptarget interface for declare mapper functions
George Rokos via Phabricator via Openmp-commits
openmp-commits at lists.llvm.org
Tue Jun 4 12:00:18 PDT 2019
grokos added a comment.
In D60972#1529265 <https://reviews.llvm.org/D60972#1529265>, @lildmh wrote:
> In D60972#1529238 <https://reviews.llvm.org/D60972#1529238>, @Hahnfeld wrote:
> > In D60972#1529215 <https://reviews.llvm.org/D60972#1529215>, @lildmh wrote:
> > > In D60972#1529151 <https://reviews.llvm.org/D60972#1529151>, @Hahnfeld wrote:
> > >
> > > > Moreover, I'd question the following things:
> > > >
> > > > 1. Why are we back to `__kmpc_?` naming? Most other functions specific to libomptarget are called `__tgt_?`.
> > >
> > >
> > > There are other functions in libomptarget starting with `__kmpc_`, for example, `__kmpc_push_target_tripcount`.
> > > My understanding is anything that does not directly call the device starting with `__kmpc_`. The IBM and Intel compiler people seem to be okay with this naming.
> > Yes, this is the only function AFAICS and it has a comment "will be revised". All other functions related to mapping start with `__tgt` so unless there is good incentive, we should follow this naming convention.
> Sure, I do prefer `__tgt`, as long as everyone else is okay with it.
Yes, please use a name that starts with `__tgt`. Names starting with `__kmpc` are meant for the libomp host runtime specifically. `__kmpc_push_tripcount` was implemented in libomptarget in a rush and the implementation is incorrect, it will be transferred to libomp and re-implemented correctly.
CHANGES SINCE LAST ACTION
More information about the Openmp-commits