[Openmp-commits] [PATCH] D64219: [OpenMP][NFCI] Cleanup the target worksharing implementation

Johannes Doerfert via Phabricator via Openmp-commits openmp-commits at lists.llvm.org
Thu Jul 4 12:50:49 PDT 2019


jdoerfert created this revision.
jdoerfert added a reviewer: openmp-commits.
Herald added a subscriber: mgorny.
Herald added a project: OpenMP.

Note: WIP patch 3/3 to go with a RFC for the device RTL design (see D64218 <https://reviews.llvm.org/D64218>)

This NFCI patch includes the following cleanup steps:

- Rename loop.cu to worksharing.cpp.
- Adjust most of the code according to the LLVM coding style, especially wrt. variable and method names.
- Document parts of the code with doxygen comments.
- Wrap CUDA specific calls into __kmpc_impl_XXX functions and define them in an own target_impl.h file.
- Use macro generators to reduce code duplication.


Repository:
  rG LLVM Github Monorepo

https://reviews.llvm.org/D64219

Files:
  openmp/libomptarget/deviceRTLs/nvptx/CMakeLists.txt
  openmp/libomptarget/deviceRTLs/nvptx/src/loop.cu
  openmp/libomptarget/deviceRTLs/nvptx/src/target_impl.h
  openmp/libomptarget/deviceRTLs/nvptx/src/worksharing.cpp

-------------- next part --------------
A non-text attachment was scrubbed...
Name: D64219.208074.patch
Type: text/x-patch
Size: 62997 bytes
Desc: not available
URL: <http://lists.llvm.org/pipermail/openmp-commits/attachments/20190704/8ff2de92/attachment-0001.bin>


More information about the Openmp-commits mailing list