[Openmp-commits] [PATCH] kmp_lock: Change return type of release functions from void to int
james.h.cownie at intel.com
Thu Apr 9 06:46:17 PDT 2015
I think it would be cleaner if you defined the new constants as KMP_LOCK_RELEASED and KMP_LOCK_STILL_HELD, then the non-nested lock implementations can sensibly return KMP_LOCK_RELEASED (rather than an explicit zero), which would be preferable to the explicit "0" they return at the moment.
More information about the Openmp-commits