<div dir="ltr"><div class="gmail_quote"><div dir="ltr" class="gmail_attr">On Mon, 6 May 2019 at 09:26, Jesper Antonsson via llvm-dev <<a href="mailto:llvm-dev@lists.llvm.org">llvm-dev@lists.llvm.org</a>> wrote:<br></div><blockquote class="gmail_quote" style="margin:0px 0px 0px 0.8ex;border-left:1px solid rgb(204,204,204);padding-left:1ex">I agree, addressable unit size is probably a better abstraction.<br>
However, in the lib/CodeGen directory alone, there's some 785 uses of<br>
the word "byte" and a significant fraction of the code that we want to<br>
modify is using the byte terminology today. An example of unmodified<br>
code from my showcase patch set:<br>
<br>
    assert(!(Shift & 0x7) == 0 &&<br>
           "Shifts not aligned on Bytes are not supported.");<br>
    uint64_t Offset = Shift / 8;<br>
    unsigned TySizeInBytes = Origin->getValueSizeInBits(0) / 8;<br>
    assert(!(Origin->getValueSizeInBits(0) & 0x7) == 0 &&<br>
           "The size of the original loaded type is not a <br>
           "multiple of a byte.");<br>
<br>
How would you prefer we handle this? If we only remove the magic<br>
numbers using getAddressableUnitSize() instead of getBitsPerByte() we'd<br>
get some mixed terminology. If the community is ok with that, we're<br>
happy to do this. If we would go for changing the terminology overall,<br>
then the work and the patch sizes would grow considerably.<br>
<br><br></blockquote><div><br></div><div>Although the above is mentioning bytes, looking at the "/ 8"   and "& 0x7" makes it look like the author meant octets and not bytes.</div><div>Bytes can be any size of bits. Octets are only ever 8 bits.</div><div><br></div><div><br></div><div> <br></div></div></div>