<div dir="ltr">The coding guidelines say:<div>> Function names should be verb phrases (as they represent actions), and command-like function should be imperative. The name should be camel case, and start with a lower case letter (e.g. openFile() or isFoo()).</div><div><br></div><div>This means that functions that just compute or access a value (no side-effects) should be named e.g. `getParent()`, rather than `parent()` as they are in e.g. the standard library.</div><div><br></div><div>This is not a rule that is particularly strictly observed in practice :-)</div><div>Personally I find it adds noise and obscures the important difference between functions called mostly for their side-effects and those called to get at a value.</div><div><br></div><div>Swift's coding guidelines state this quite concisely:</div><div>> Name functions and methods according to their side-effects</div><div>> Those without side-effects should read as noun phrases, e.g. x.distance(to: y), i.successor().<br></div><div>> Those with side-effects should read as imperative verb phrases, e.g., print(x), x.sort(), x.append(y).</div><div>(<a href="https://swift.org/documentation/api-design-guidelines/#strive-for-fluent-usage">https://swift.org/documentation/api-design-guidelines/#strive-for-fluent-usage</a>)</div><div><br></div><div>How do people feel about this change? Clearly a mix of these styles will exist in practice for a long time (this is already the case!) but which should be encouraged?</div><div><br></div><div>(*dons flame-retardant suit and mumbles something about Java*)</div></div>