<div dir="ltr"><br><div class="gmail_extra"><br><div class="gmail_quote">On Tue, May 24, 2016 at 3:50 PM, Duncan P. N. Exon Smith <span dir="ltr"><<a href="mailto:dexonsmith@apple.com" target="_blank">dexonsmith@apple.com</a>></span> wrote:<br><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex">Zooming into the command-line option bike-shed:<br></blockquote><div><br></div><div>Let's avoid bikeshedding until the exact requirements are clear.</div><div><br></div><div>-- Sean Silva</div><div> </div><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex">
<span class=""><br>
> On 2016-May-24, at 15:41, Vedant Kumar via llvm-dev <<a href="mailto:llvm-dev@lists.llvm.org">llvm-dev@lists.llvm.org</a>> wrote:<br>
><br>
> At its core I don't think -fprofile-instr-generate *implies* FE-based instrumentation. So, I'd like to see the driver do this (on all platforms):<br>
><br>
>  * -fprofile-instr-generate: IR instrumentation<br>
>  * -fprofile-instr-generate=IR: IR instrumentation<br>
>  * -fprofile-instr-generate=FE: FE instrumentation<br>
>  * -fprofile-instr-generate -fcoverage-mapping: FE + coverage instrumentation<br>
<br>
</span>I feel like this would be simpler:<br>
  * -fcoverage-mapping: -fprofile-instr-generate=FE + coverage instrumentation<br>
<br>
Maybe there's a downside I'm not seeing though?<br>
<br>
Also, I don't like "FE".  Maybe "source"?  And instead of "IR", "llvm-ir" or something?<br>
<span class=""><br>
> It's a bit ugly because the meaning of -fprofile-instr-generate becomes context-sensitive. But, (1) it doesn't break existing common workflows and (2) it makes it easier to ship IRPGO. The big caveat here is that we'll need to wait a bit and see if our internal users are OK with this.<br>
><br>
> One alternative is to introduce a separate driver flag for IRPGO. This might not work well for Sony's existing users. I'd be interested in any feedback about this approach.<br>
<br>
</span>My first thought is `-mprofile-instr-generate`, since if it's not in the frontend then "-f" doesn't really make sense...</blockquote></div><br></div></div>