<div dir="ltr"><br><div class="gmail_extra"><br><div class="gmail_quote">On Thu, Apr 21, 2016 at 11:44 AM, Duncan P. N. Exon Smith <span dir="ltr"><<a href="mailto:dexonsmith@apple.com" target="_blank">dexonsmith@apple.com</a>></span> wrote:<br><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex"><span class=""><br>
> On 2016-Apr-21, at 11:41, Mehdi Amini <<a href="mailto:mehdi.amini@apple.com">mehdi.amini@apple.com</a>> wrote:<br>
><br>
><br>
>> On Apr 21, 2016, at 11:25 AM, Teresa Johnson <<a href="mailto:tejohnson@google.com">tejohnson@google.com</a>> wrote:<br>
>><br>
>> I am currently making some BitcodeWriter changes that involve some refactoring, and am thinking for the Nth time that it would be much nicer to have a class instead of passing around a long list of parameters. I am thinking of biting the bullet and doing that - any objections?<br>
><br>
> In general I'm worried about having single gigantic class that keep many data members, this goes against <a href="https://en.wikipedia.org/wiki/Single_responsibility_principle" rel="noreferrer" target="_blank">https://en.wikipedia.org/wiki/Single_responsibility_principle</a> and makes it hard to track what is initialized, where, and under which condition (basically one of the reason why global variables are not welcome). The code is almost always easier to understand with small separated components (yes many places are drifting a lot in LLVM...).<br>
><br>
> Not to say that it can't be done, just that it requires a lot of care.<br>
<br>
</span>I don't think we should throw *all* the state in.  But some of the state<br>
is passed everywhere.<br>
<br>
At least (off the top of my head):<br>
<br>
  - ValueEnumerator&<br>
  - BitstreamWriter&<br></blockquote><div><br></div><div>Agree. Also the ModuleSummaryIndex, and the Module in the case of writing bitcode for a module as opposed to a combined index (which should probably be different derived classes). I'll try to be sensible, but you can let me know if it is too much when I have a patch. =)</div><div><br></div><div>Good idea on lower-casing function names at the same time, at least for anything that moves into the class.</div><div><br></div><div>Thanks,</div><div>Teresa</div></div><br><br clear="all"><div><br></div>-- <br><div class="gmail_signature"><span style="font-family:Times;font-size:medium"><table cellspacing="0" cellpadding="0"><tbody><tr style="color:rgb(85,85,85);font-family:sans-serif;font-size:small"><td nowrap style="border-top-style:solid;border-top-color:rgb(213,15,37);border-top-width:2px">Teresa Johnson |</td><td nowrap style="border-top-style:solid;border-top-color:rgb(51,105,232);border-top-width:2px"> Software Engineer |</td><td nowrap style="border-top-style:solid;border-top-color:rgb(0,153,57);border-top-width:2px"> <a href="mailto:tejohnson@google.com" target="_blank">tejohnson@google.com</a> |</td><td nowrap style="border-top-style:solid;border-top-color:rgb(238,178,17);border-top-width:2px"> 408-460-2413</td></tr></tbody></table></span></div>
</div></div>