<html>
<head>
<meta content="text/html; charset=utf-8" http-equiv="Content-Type">
</head>
<body text="#000000" bgcolor="#FFFFFF">
Elena,<br>
<br>
I'd like to propose that we move forward with<a
href="http://reviews.llvm.org/D17270"> Artur's original patch</a>
and separate the discussion of how we might change our intrinsic
naming scheme. Artur's patch is addressing a correctness problem;
that has to overrule stylistic concerns. We are seeing failures in
our nightly tests due to this issue on an ongoing basis, and I'd
really like to get the correctness issue resolved in the immediate
future.<br>
<br>
I am more than happy to continue the discussion about better naming
schemes - in particular, I like you're idea of potentially allowing
forward references - but I strongly feel we need to decouple it from
a bug fix for a correctness issue.<br>
<br>
Philip<br>
<br>
<div class="moz-cite-prefix">On 02/24/2016 09:28 AM, Philip Reames
via llvm-dev wrote:<br>
</div>
<blockquote cite="mid:56CDE846.1050307@philipreames.com" type="cite">
<meta http-equiv="content-type" content="text/html; charset=utf-8">
This probably needs broader discussion. We have an existing
naming mechanism for polymorphic intrinsics; Elena is proposing a
new one to avoid making the names for various load/store
intrinsics particularly ugly. <br>
<br>
My personal take:<br>
1) I like the cleaner naming scheme.<br>
2) I'm not sure the additional complexity is worth it. (Not
specific to the particular implementation proposed here.)<br>
3) I have no strong preference other than that the
@llvm.masked_load (and friends) intrinsics support alternate
address spaces in some form in the near future.<br>
<br>
What do others think?<br>
<br>
Philip<br>
<div class="moz-forward-container"><br>
<br>
-------- Forwarded Message --------
<table class="moz-email-headers-table" border="0"
cellpadding="0" cellspacing="0">
<tbody>
<tr>
<th valign="BASELINE" nowrap="nowrap" align="RIGHT">Subject:
</th>
<td>[PATCH] D17497: Support arbitrary address space for
intrinsics</td>
</tr>
<tr>
<th valign="BASELINE" nowrap="nowrap" align="RIGHT">Date:
</th>
<td>Mon, 22 Feb 2016 08:39:38 +0000</td>
</tr>
<tr>
<th valign="BASELINE" nowrap="nowrap" align="RIGHT">From:
</th>
<td>Elena Demikhovsky <a moz-do-not-send="true"
class="moz-txt-link-rfc2396E"
href="mailto:elena.demikhovsky@intel.com"><elena.demikhovsky@intel.com></a></td>
</tr>
<tr>
<th valign="BASELINE" nowrap="nowrap" align="RIGHT">Reply-To:
</th>
<td><a moz-do-not-send="true"
class="moz-txt-link-abbreviated"
href="mailto:reviews+D17497+public+90f3d1b9468ba8ca@reviews.llvm.org">reviews+D17497+public+90f3d1b9468ba8ca@reviews.llvm.org</a></td>
</tr>
<tr>
<th valign="BASELINE" nowrap="nowrap" align="RIGHT">To: </th>
<td><a moz-do-not-send="true"
class="moz-txt-link-abbreviated"
href="mailto:elena.demikhovsky@intel.com">elena.demikhovsky@intel.com</a>,
<a moz-do-not-send="true"
class="moz-txt-link-abbreviated"
href="mailto:apilipenko@azulsystems.com">apilipenko@azulsystems.com</a>,
<a moz-do-not-send="true"
class="moz-txt-link-abbreviated"
href="mailto:listmail@philipreames.com">listmail@philipreames.com</a>,
<a moz-do-not-send="true"
class="moz-txt-link-abbreviated"
href="mailto:ayal.zaks@intel.com">ayal.zaks@intel.com</a>,
<a moz-do-not-send="true"
class="moz-txt-link-abbreviated"
href="mailto:Matthew.Arsenault@amd.com">Matthew.Arsenault@amd.com</a>,
<a moz-do-not-send="true"
class="moz-txt-link-abbreviated"
href="mailto:pjcoup@gmail.com">pjcoup@gmail.com</a></td>
</tr>
<tr>
<th valign="BASELINE" nowrap="nowrap" align="RIGHT">CC: </th>
<td><a moz-do-not-send="true"
class="moz-txt-link-abbreviated"
href="mailto:llvm-commits@lists.llvm.org">llvm-commits@lists.llvm.org</a></td>
</tr>
</tbody>
</table>
<br>
<br>
<pre>delena created this revision.
delena added reviewers: apilipenko, reames, Ayal, arsenm, pjcoup.
delena added a subscriber: llvm-commits.
delena set the repository for this revision to rL LLVM.
This is an alternative proposal for supporting address space in intrinsics. It's applicable for any intrinsic, not only masked-load-store.
Related to <a moz-do-not-send="true" class="moz-txt-link-freetext" href="http://reviews.llvm.org/D17270">http://reviews.llvm.org/D17270</a>
I this proposal I add non-zero address space suffix to intrinsic name. The original name looks like
@llvm.xxx.xxx
The same name with address space 1 :
@llvm.xxx.xxx.a_1
(I did not update documentation. I'll do this if the proposed change looks reasonable for reviewers ).
Repository:
rL LLVM
<a moz-do-not-send="true" class="moz-txt-link-freetext" href="http://reviews.llvm.org/D17497">http://reviews.llvm.org/D17497</a>
Files:
../include/llvm/IR/IRBuilder.h
../include/llvm/IR/Intrinsics.h
../lib/IR/Function.cpp
../lib/IR/IRBuilder.cpp
../lib/IR/Verifier.cpp
../test/Transforms/LoopVectorize/X86/gather_scatter.ll
</pre>
<br>
</div>
<br>
<br>
<fieldset class="mimeAttachmentHeader"></fieldset>
<br>
<pre wrap="">_______________________________________________
LLVM Developers mailing list
<a class="moz-txt-link-abbreviated" href="mailto:llvm-dev@lists.llvm.org">llvm-dev@lists.llvm.org</a>
<a class="moz-txt-link-freetext" href="http://lists.llvm.org/cgi-bin/mailman/listinfo/llvm-dev">http://lists.llvm.org/cgi-bin/mailman/listinfo/llvm-dev</a>
</pre>
</blockquote>
<br>
</body>
</html>