<div dir="ltr"><br><div class="gmail_extra"><br><br><div class="gmail_quote">On Tue, Nov 12, 2013 at 4:19 PM, Chandler Carruth <span dir="ltr"><<a href="mailto:chandlerc@google.com" target="_blank">chandlerc@google.com</a>></span> wrote:<br>
<blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex"><div dir="ltr"><div class="gmail_extra"><br><div class="gmail_quote"><div class="im">On Tue, Nov 12, 2013 at 4:14 PM, Chris Lattner <span dir="ltr"><<a href="mailto:clattner@apple.com" target="_blank">clattner@apple.com</a>></span> wrote:<br>

<blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex"><div><div><blockquote type="cite"><div dir="ltr"><div class="gmail_extra"><div class="gmail_quote"><div>I'm moderately opposed to just encoding these in a string format. I think we can do something substantially better both for space, time, and readability. Fundamentally, there is no reason for the original metadata node you describe to not *encode* its operands into a dense bit-packed blob of memory. We can still expose APIs that manipulate them as separate entities, and have the AsmPrinter and AsmParser map back and forth with nice human-readable forms. But even a simple varint encoding will be both smaller and faster than ascii.</div>

</div></div></div></blockquote><div><br></div></div><div>I guess you could make it work, but would that actually be simpler than what is proposed?  If it is denser, how much denser would it have to be to justify the complexity?</div>

</div></blockquote><div><br></div></div><div>I don't think it would be more complex than a string encoding. At least, I'm not imagining we want to be super clever here.</div><div><br></div><div>I could even imagine doing a versioned giant bitfield and using the version to handle auto-upgrade...</div>
<div class="im">
<div> </div><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex"><div><div><br><blockquote type="cite"><div dir="ltr"><div class="gmail_extra"><div class="gmail_quote">

<div>Just to be clear, I still want the nice format (much like your proposed format, but maybe with the numbers outside of the "s) in the textual IR, I just think we should use a more direct and efficient in-memory encoding (and in-bitcode encoding if that isn't already suitably dense).</div>


</div></div></div>
</blockquote></div></div><br><div>Where would the encoding schema be specified?</div></blockquote><div><br></div></div><div>Same question applies to a string encoding. We have to define the schema somewhere clearly. I'm just lobbying for the textual IR and the APIs to both operate directly on N fields, and just make the memory representation dense.</div>
</div></div></div></blockquote><div><br></div><div>The difference here is that debug info parsing code would know the schema externally - so the metadata itself wouldn't have to be self-describing or typed in any way. Just a flat series of bytes of a fixed size would be sufficient. (then leaving out the fields that refer to other IR constructs such as functions, variables, etc)<br>
<br>But if we could make general metadata generally more compact that'd be nice too and maybe sufficient/instead/not worth the added complexity in debug info code of pulling out fields in the debug info handling code.</div>
<div> </div><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex"><div dir="ltr"><div class="gmail_extra"><div class="gmail_quote"><div class="im">
<div> </div><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex"><div><br></div><div>Note that there are simple things that can be done to make MDNodes more efficient in common cases.  The CallbackVH is only necessary when pointing to Value*’s that are not MDNode/MDString, and Constants-other-than-GlobalValue.  If we make MDNode detect when it has “all-immortal” operands (like most debug info nodes) then we could just store Value*’s directly.  This would be a completely invisible implementation improvement, but would not provide the same level of improvement as the “flatten into strings” approach.  The two are quite complementary.</div>

</blockquote></div></div><br>Yea, I'd rather go for at least a bit more dense than that, but maybe we should do this step-by-step.</div></div>
<br>_______________________________________________<br>
LLVM Developers mailing list<br>
<a href="mailto:LLVMdev@cs.uiuc.edu">LLVMdev@cs.uiuc.edu</a>         <a href="http://llvm.cs.uiuc.edu" target="_blank">http://llvm.cs.uiuc.edu</a><br>
<a href="http://lists.cs.uiuc.edu/mailman/listinfo/llvmdev" target="_blank">http://lists.cs.uiuc.edu/mailman/listinfo/llvmdev</a><br>
<br></blockquote></div><br></div></div>