<div dir="ltr"><div class="gmail_extra"><br><div class="gmail_quote">On Fri, Oct 18, 2013 at 11:08 AM, Andrew Trick <span dir="ltr"><<a href="mailto:atrick@apple.com" target="_blank" class="cremed">atrick@apple.com</a>></span> wrote:<br>
<blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex"><div class="im"><blockquote type="cite"><div style="font-size:12px;font-style:normal;font-variant:normal;font-weight:normal;letter-spacing:normal;line-height:normal;text-align:start;text-indent:0px;text-transform:none;white-space:normal;word-spacing:0px">
<blockquote type="cite">The initial documentation and patches name these intrinsics in a<br>"webkit" namespace. This clarifies their current purpose and conveys<br>that they haven't been standardized for other JITs yet. If someone on<br>
the on the dev list says "yes we want to use these too, just the way<br>they are", then we can just drop the "webkit" name. More likely, we<br>will continue improving their functionality for WebKit until some<br>
point in the future when another JIT customer tells us they would<br>like<br>to use the intrinsics but really want to change the interface. At<br>that<br>point, we can review this again with the goal of standardization and<br>
backward compatibility, then promote the name. WebKit is maintained<br>against LLVM trunk so can be quickly adjusted to a new interface. The<br>same may not be true of other JITs.<br></blockquote><br>I recommend, this being the case, to replace 'webkit' with 'experimental'. Having webkit in the name implies some dependence on webkit, and there is none. Plus, this functionality will be used by outside projects as soon as it lands in trunk, and I suspect that having webkit in the initial name will end up as a naming incongruity that no one will really think is worth the effort to change.<br>
</div></blockquote><div><br></div></div><div>You’re correct that there is no dependence. I’m fine dropping the webkit name, but only if we can go straight to the final name (no need for “experimental”).</div><div><br></div>
<div>Again, the only reason to start with the webkit name is that it’s easy to change webkit later to use different intrinsics. I was waiting to see how much interest there is in using these instrinsics as-is for other clients. So far, there seems to be strong interest. If there isn’t much debate regarding the intrinsic format then I’ll drop the webkit name.</div>
</blockquote></div><br>I'm strongly against naming this "webkit" or anything else to do with any other single consumer of LLVM which is not even an LLVM project. It is really confusing and implies a whole boat of things that aren't true.</div>
<div class="gmail_extra"><br></div><div class="gmail_extra">I don't understand why you are pushing for "the final name or the webkit name". I think the recommendation of "experimental" is great. It clarifies that the exact interface isn't fully baked and may change, and clients must be prepared to update following LLVM trunk as opposed to expecting full backwards compatibility.</div>
<div class="gmail_extra"><br></div><div class="gmail_extra">If this feature were *only* applicable to WebKit, I'm not even sure it would belong in the main open source repository. But it isn't, it's a really interesting general purpose feature for doing dynamic patching of call sites, and we should figure out a way to design and evolve it as such.</div>
</div>